元の KB 番号: 9067236
現象
ユーザーが Microsoft Outlook で暗号化された電子メール メッセージを送信しようとすると、 Encryption の問題 ダイアログが表示されます。 ダイアログには、次の警告メッセージが表示されます。
Microsoft Outlook では、次の受信者に証明書が見つからないか無効であるか、競合またはサポートされていない機能があるため、このメッセージの暗号化に問題がありました。
このダイアログには、次のスクリーンショットに示すように、暗号化されていないメール メッセージまたは暗号化されたメール メッセージを送信するオプション、または送信を取り消すオプションが表示されます。
原因
次の条件がすべて当てはまる場合、警告は誤検知であり、無視しても問題ありません。
メッセージ暗号化は、セキュリティで保護された多目的インターネット メール拡張機能 (S/MIME) です。
送信者の S/MIME 証明書は、RSA 公開キー暗号化アルゴリズムを使用します。
受信者の S/MIME 証明書は、ECC 公開キー暗号化アルゴリズムを使用します。
ヒント
S/MIME 証明書で RSA または ECC が使用されているかどうかを確認するには、証明書の Public key 属性を調べます。 属性値は、 RSA
または ECC
です。 Microsoft Certificate Manager ツール (certmrg.msc) で証明書属性を表示できます。
回避策
"誤検知" 警告を回避するには、Encryption の問題ダイアログで Continue を選択して、S/MIME で暗号化されたメッセージを送信します。
Note
暗号化が必要な場合は、 暗号化されていない を選択しないことをお勧めします。
解決方法
Outlook for Microsoft 365 バージョン 16.0.18227.20000 以降のバージョンでは、管理者はこの問題に対する "誤検知" 警告を完全に抑制できます。 これを行うには、次のいずれかの方法を選択します。
注: この解決策により、 Encryption の問題 他の問題 (受信者証明書が見つからない、無効な場合など) に関するダイアログが表示されなくなります。
重要
このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 したがって、次の手順を注意深く実行してください。 保護のために、レジストリを変更する前にレジストリをバックアップして、問題が発生した場合にレジストリを復元できるようにします。 レジストリのバックアップと復元方法の詳細は、「Windows のレジストリのバックアップおよび復元の方法」を参照してください。
方法 A: ドメインに参加しているユーザーの警告を抑制する
ドメイン コントローラーでレジストリ エディター (Regedit) を実行して、グループ ポリシーを更新します。
HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\16.0\Outlook\Security
に移動します。SkipProblemsDialogForDhCertMismatch
という名前の DWORD エントリを追加します。 DWORD 値を1
に設定します。
方法 B: 個々のユーザーの警告を抑制する
ユーザーのコンピューターで Regedit を実行します。
HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Security
に移動します。SkipProblemsDialogForDhCertMismatch
という名前の DWORD エントリを追加します。 DWORD 値を1
に設定します。Outlook を再起動します。