現象
サポートと回復アシスタント (SaRA) で Outlook Advanced Diagnostics シナリオを実行すると、結果はオフライン スキャンが実行されたことを示します。
注:
Microsoft サポートと Recovery Assistant のシナリオは、新しい Outlook for Windows では使用できません。
原因
警告
レジストリ エディタや他の方法を使用してレジストリを変更する際、適切に変更しないと重大な問題を引き起こす可能性があります。 場合によっては、オペレーティング システムの再インストールが必要になります。 こうした問題の修復について、マイクロソフトはいかなる保証もいたしません。 レジストリの変更はユーザー自身の責任において行ってください。
このアラートは、Windows レジストリで次のデータが構成されている場合に発生します。 この構成により、Outlook データへのアクセスを試みるプログラムからの要求が自動的に拒否されます。
Outlook 2010 以降のバージョン:
キー: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Security
DWORD: AdminSecurityMode
値: 3
次のレジストリ キーのいずれかまたは両方:
キー: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Security
DWORD: PromptOOMAddressInformationAccess
値: 0
または
キー: HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\x.0\Outlook\Security
DWORD: PromptOOMAddressBookAccess
値: 0
注:
上記のレジストリ キー パスでは、x.0 は Outlook のバージョン (17.0 = Outlook 2019、16.0 = Outlook 2016、15.0 = Outlook 2013、14.0 = Outlook 2010) に対応しています。
解決方法
Outlook のフル スキャンを実行する必要がある場合は、レジストリ値やPromptOOMAddressBookAccess
レジストリ値をPromptOOMAddressInformationAccess
一時的に 1 に変更できます。 この変更により、Outlook は Outlook データにアクセスするための要求 (プログラムから) を自動的に拒否しなくなり、代わりにアクセス要求の承認を求められます。 この機能の既定の設定は、値 1 です。
これらのレジストリ値に使用できる値データを次に示します。
0: 自動的に拒否する
1: ユーザーにプロンプトを表示する
2: 自動的に承認する
ポリシー ハイブ内の上記のレジストリ データは、グループ ポリシーによって制御される場合があります。 これらの設定を完全に変更するには、ポリシーを変更する必要がある場合があります。