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Outlook で追加のメールボックスから検索すると、"問題が発生し、検索を完了できませんでした" というエラー メッセージが表示される

現象

次のような状況で問題が発生します。

  • セカンダリ メールボックスへのフル アクセスのアクセス許可が付与されます。
  • メールボックスを追加の Exchange アカウントとして Microsoft Outlook for Microsoft 365 プロファイルに追加します。
  • そのメールボックスから検索を実行します。

この場合に、次のようなエラー メッセージが表示されます。

問題が発生し、検索を完了できませんでした。

ネットワーク接続に問題があるようです。

このエラーが発生した場合、[ 代わりにコンピューターを見てみましょう ] オプションを選択すると、予想される検索結果が表示される場合があります。

原因

これは、Exchange オンライン検索サービスの既知の制限です。 この問題は、Outlook クライアントがプライマリ メールボックス ユーザーの資格情報を使用してセカンダリ メールボックスから検索を実行する場合に発生します。

回避策

重要

このセクションの手順の実行には注意が必要です。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 変更する前に、問題の発生に備えて復元用にレジストリのバックアップを作成してください。

この問題を回避するには、次のいずれかの方法を使用します。

  • ローカル検索を使用するためにフォールバックする前に、Exchange が検索結果を提供するまで Outlook が待機する時間を長くします。

    時間を長くするには、レジストリ値を作成します ServerAssistedSearchTimeout 。 詳細については、この Outlook グローバル カスタマー サービス & サポート チームのブログ記事を参照してください。

    グループ ポリシーレジストリのパス HKEY_CURRENT_USER\software\policies\microsoft\office\16.0\outlook\search
    値の名前 ServerAssistedSearchTimeout
    値の種類 REG_DWORD
    値のデータ ミリ秒単位。 たとえば、5,000 は 5 秒を表します。

    注:

    OCT レジストリ パスは です HKEY_CURRENT_USER\software\microsoft\office\16.0\outlook\search

    テストするには、値を 5 秒に設定します。 3 秒や 4 秒など、短い時間でも機能する場合があります。

  • [コンピューター を見てみましょう ] を選択して、エラーが発生するたびにローカル Windows デスクトップ検索を開始します。

  • Outlook の設定を変更して、サービスの検索機能の使用を停止します。 これを行うには、DisableServerAssistedSearch レジストリ キーを作成します。 詳細については、この Outlook グローバル カスタマー サービス & サポート チームのブログ記事を参照してください。

    グループ ポリシーレジストリのパス HKEY_CURRENT_USER\software\policies\Microsoft\office\16.0\outlook\search
    値の名前 DisableServerAssistedSearch
    値の種類 REG_DWORD
    値のデータ 1

    注:

    OCT レジストリ パスは です HKEY_CURRENT_USER\software\microsoft\office\16.0\outlook\search

  • Exchange キャッシュ モードの使用を停止するように追加のメールボックスを設定するには、この Microsoft サポートの記事を参照してください。

  • 共有メールボックスを追加のメールボックスとして作成します。 詳細については、[共有メールボックスの作成] を参照してください。