チュートリアル:Power BI Desktop で Excel ブックから魅力的なレポートを作成する

適用対象: Power BI Desktop Power BI サービス

このチュートリアルでは、開始から終了まで 20 分で美しいレポートを作成します。

Screenshot of finished Power BI report.

上司は、最新の売上高に関するレポートを見たいと考えています。 次の内容を含むエグゼクティブ サマリを要求してきました。

  • 最も利益が多かったのは、どの年のどの月か?
  • 会社が最も成功を収めたのは、どこ (国/地域別) か?
  • 会社が投資を継続する必要があるのは、どの製品とセグメントか?

サンプルの財務ブックを使用すると、このレポートを即座に作成できます。 最終的なレポートは次のようになります。 それでは始めましょう。

このチュートリアルで学習する内容は次のとおりです。

  • サンプル データを 2 つの異なる方法でダウンロードする
  • 変換を数回行ってデータを準備する
  • タイトル、3 つのビジュアル、スライサーを含むレポートを作成する
  • 仕事仲間と共有できるように、レポートを Power BI サービスに発行する

前提条件

データを取得する

このチュートリアルのデータは、2 つの方法のいずれかを使用して取得できます。

Power BI Desktop でデータを取得する

Power BI Desktop を開いたときに、空のキャンバスから [Try a sample dataset] (サンプル セマンティック モデルを試す) を選びます。

Screenshot of Try a sample semantic model on the canvas.

Power BI Desktop からこのチュートリアルに移動してきた場合は、 [データの読み込み] を選択します。

Screenshot of Two ways to use sample data > Load data.

サンプルのダウンロード

サンプル ブックを直接ダウンロードすることもできます。

  1. 財務サンプルの Excel ブックをダウンロードします。
  2. Power BI Desktop を開きます。
  3. [ホーム] リボンの [データ] セクションで、 [Excel] を選択します。
  4. サンプルのブックを保存した場所に移動し、 [開く] を選択します。

データの準備

[ナビゲーター] には、データを "変換する" または "読み込む" オプションがあります。 [ナビゲーター] には、データの範囲が正しいことを確認できるように、データのプレビューが表示されます。 数値データ型は斜体で示されます。 変更する必要がある場合は、データを読み込む前に変換します。 後で見やすいように視覚化するために、ここでデータを変換する必要があります。 変換を行うたびに、 [クエリの設定][適用したステップ] の一覧にそれが追加されます

  1. [財務] テーブルを選択し、 [データの変換] を選択します。

    Screenshot of Power BI Navigator with Financial sample data.

  2. [販売数] 列を選択します。 [変換] タブで、 [データ型] を選択したら、 [整数] を選択します。 [現在のものを置換] を選択して、列の型を変更します。

    ユーザーが行うデータ クリーニングの手順で最も頻度が高いのは、データ型の変更です。 この場合、販売数は 10 進数形式です。 0\.2 や 0.5 の販売数は意味がありません。 では、それを整数に変更しましょう。

    Screenshot of changing a decimal number to a whole number.

  3. [セグメント] 列を選択します。 後ほどグラフ内でセグメントを見やすくする作業を行いますので、セグメント列の書式設定を行いましょう。 [変換] タブで、 [書式][大文字] の順に選択します。

    screenshot of changing lowercase to uppercase headings.

  4. 次に、列名を [月の名前] から [月] に短縮します。 [月の名前] 列をダブルクリックして、列名を [月] に変更します。

    Screenshot of shortening column name.

  5. [製品] 列で、ドロップダウンを選択し、 [Montana] の横にあるボックスをオフにします。

    Montana 製品は先月に製造中止になっていることがわかっているので、混乱を避けるために、このデータをフィルター処理してレポートから除外する必要があります。

    Screenshot of deleting Montana values.

  6. 各変換が、 [クエリの設定][適用したステップ] の一覧に追加されたことがわかります。

    Screenshot of list of applied steps.

  7. [ホーム] タブに戻り、[閉じて適用] を選択します。 データは、レポートを作成するための準備がほとんど整いました。

    [フィールド] の一覧にシグマ記号が表示されているのがわかりますか? Power BI によって、これらのフィールドが数値であることが検出されました。 さらに、Power BI によって、カレンダー記号が付いたデータ フィールドも示されます。

    Screenshot of Fields list with numeric fields and date field.

追加の手順: DAX で式を記述する

DAX 数式言語で "メジャー" を記述し、"テーブル" を作成すると、データ モデリング時に非常に大きな効果を発揮します。 DAX の詳細については、Power BI のドキュメントを参照してください。 ここでは、基本的な式を作成して、2 つのテーブルを結合します。

  1. [ホーム] リボンで、 [新しいメジャー] を選択します。

    Screenshot of New measure icon on the Home ribbon.

  2. この式を入力して、"Units Sold" 列にすべての数値を追加します。

    Total Units Sold = SUM(financials[Units Sold])    
    
  3. チェック マークを選択してコミットします。

    Screenshot of DAX expression Total Units Sold.

  4. 次に、左側の [データ] ビューを選択します。

    Screenshot of Data View icon.

  5. [ホーム] リボンで、 [新しいテーブル] を選択します。

    Screenshot of New Table icon.

  6. 次の式を入力して、2013 年 1 月 1 日から 2014 年 12 月 31 日までのすべての日付が含まれる Calendar テーブルを作成します。

    Calendar = CALENDAR(DATE(2013,01,01),Date(2014,12,31))    
    
  7. チェック マークを選択してコミットします。

    Screenshot of DAX expression Calendar.

  8. ここで、左側の [モデル] ビューを選択します。

    Screenshot of Model View icon.

  9. financials テーブルの [Date] フィールドを Calendar テーブルの [Date] フィールドにドラッグし、これらのテーブルを結合して、テーブル間の "リレーションシップ" を作成します。

    Screenshot of relationship between Date fields.

レポートの構築

データの変換と読み込みが完了したので、次にレポートを作成します。 右側にある [フィールド] ウィンドウに、作成したデータ モデルのフィールドが表示されます。

一度に 1 つずつビジュアルを作成して、最終的なレポートを完成させましょう。

Screenshot of all the elements of the report, by number.

ビジュアル 1: タイトルの追加

  1. [挿入] リボンで、 [テキスト ボックス] を選択します。 "エグゼクティブ サマリ - 財務レポート" と入力します。

  2. 入力したテキストを選択します。 フォント サイズを [20][太字] に設定します。

    Screenshot of formatting title.

  3. 1 行に収まるようにボックスのサイズを変更します。

ビジュアル 2: 日付別利益

利益が最も多かった月と年がわかるように折れ線グラフを作成します。

  1. [フィールド] ウィンドウの [Profit] フィールドをレポート キャンバスの空白領域にドラッグします。 Power BI では、既定により、縦棒が 1 つある縦棒グラフ (利益) が表示されます。

  2. [Date] フィールドを同じビジュアルにドラッグします。 この記事で前述した「追加の手順: DAX でテーブルを作成する」で Calendar テーブルを作成した場合は、Calendar テーブルから [Date] フィールドをドラッグします。

    Power BI によって、縦棒グラフが更新され、2 年分の利益が年別に表示されます。

    Screenshot of Profit column chart.

  3. [視覚化] ウィンドウの [フィールド] セクションで、[X 軸] の値のドロップダウンを選択します。 [日付][日付の階層] から [日付] に変更します。

    Screenshot of changing Date hierarchy to Date.

    Power BI によって、縦棒グラフが更新され、毎月の利益が表示されます。

    Screenshot of column chart by month.

  4. [視覚化] ウィンドウで、視覚化の種類を [折れ線グラフ] に変更します。

    Screentshot of changing column to bar chart.

    以上で、2014 年 12 月が最も利益が多かったことが簡単にわかるようになりました。

視覚化 3: Profit by Country/Region

どの国/地域が最も利益が多かったかを示すマップを作成します。

  1. [フィールド] ウィンドウの [Country] フィールドをレポート キャンバスの空白領域にドラッグして、マップを作成します。

  2. [Profit] フィールドをマップにドラッグします。

    Power BI によって、各場所の相対的な利益を表すバブルの表示された地図ビジュアルが作成されます。

    Screenshot of creating map chart.

    ヨーロッパは、北米より好調であるように見えます。

ビジュアル 4: 製品およびセグメント別の売上

投資する会社とセグメントを決定するための横棒グラフを作成します。

  1. 作成した 2 つのグラフをドラッグして、キャンバスの上半分に横に並べて表示します。 キャンバスの左側に少しスペースを取っておきます。

  2. レポート キャンバスの下半分の空白領域を選択します。

  3. [フィールド] ウィンドウで、Sales フィールド、Product フィールド、Segment フィールドを選択します。

    Power BI によって、集合縦棒グラフが自動的に作成されます。

  4. 上の 2 つのグラフの下にあるスペースを埋めるのに十分な幅になるように、グラフをドラッグします。

    Screenshot of a clustered column chart.

    会社は引き続き Paseo 製品に投資し、中小企業と政府のセグメントをターゲットにする必要があるように見えます。

ビジュアル 5: 年のスライサー

スライサーは、レポート ページのビジュアルを特定の選択範囲にフィルター処理するための重要なツールです。 この場合、各月および年の業績を絞り込むための、2 つの異なるスライサーを作成できます。 1 つのスライサーでは、元のテーブルの日付フィールドを使用します。 もう 1 つでは、このチュートリアルの前述の "追加の手順" で作成した日付テーブルを使用します。

元のテーブルを使用する日付スライサー

  1. [フィールド] ペインで、Financials テーブルの [Date] フィールドを選択します。 それをキャンバスの左側にある空白の領域にドラッグします。

  2. [視覚化] ウィンドウで、 [スライサー] を選択します。

    Power BI によって、数値範囲のスライサーが自動的に作成されます。

    Screenshot of Date numeric range slicer.

  3. 端をドラッグしてフィルター処理するか、右上隅の矢印を選択して別の種類のスライサーに変更することができます。

DAX テーブルを使用する日付スライサー

  1. [フィールド] ペインで、Calendar テーブルの [Date] フィールドを選択します。 それをキャンバスの左側にある空白の領域にドラッグします。

  2. [視覚化] ウィンドウで、 [スライサー] を選択します。

  3. [視覚化] ウィンドウの [フィールド] セクションで、 [フィールド] のドロップダウンを選択します。 [四半期] と [日] を削除して、[年] と [月] のみを残します。

    Screenshot of changing the Date hierarchy.

  4. 各年を展開し、ビジュアルのサイズを変更して、すべての月が表示されるようにします。

    Screenshot of date hierarchy slicer.

    完成したレポートでは、このスライサーを使用します。

これで上司が 2013 年のデータのみを表示するように要求した場合に、いずれかのスライサーを使用して、年、または各年の特定の月を選択することができます。

追加の手順: レポートを書式設定する

このレポートに対して何らかの淡色の書式設定を行って洗練さを高める必要がある場合、以下に簡単な手順をいくつか示します。

テーマ

  • [表示] リボンで、テーマを [エグゼクティブ] に変更します。

    Screenshot of selecting the Executive theme.

ビジュアルを整理する

[視覚化] ウィンドウの [書式] タブで、次の変更を行います。

Screenshot of the Format tab in the Visualizations pane.

  1. ビジュアル 2 を選択します。 [タイトル] セクションで、 [タイトルのテキスト] を "月別および年別の利益" に変更し、 [テキスト サイズ][16 pt] に変更します。 [影][オン] に切り替えます。

  2. ビジュアル 3 を選択します。 [マップ スタイル] セクションで、 [テーマ][グレースケール] に変更します。 [タイトル] セクションで、タイトルの [テキスト サイズ][16 pt] に変更します。 [影][オン] に切り替えます。

  3. ビジュアル 4 を選択します。 [タイトル] セクションで、タイトルの [テキスト サイズ][16 pt] に変更します。 [影][オン] に切り替えます。

  4. ビジュアル 5 を選択します。 [選択範囲のコントロール] セクションで、 [[すべて選択] オプションを表示する][オン] に切り替えます。 [スライサー ヘッダー] セクションで、 [テキスト サイズ][16 pt] に増加します。

タイトルの背景図形を追加する

  1. [挿入] リボンで、 [図形]>[四角形] を選択します。 それをページの一番上に配置し、ページの幅とタイトルの高さに合わせて引き伸ばします。

  2. [図形の書式設定] ウィンドウの [線] セクションで、 [透明度][100%] に変更します。

  3. [塗りつぶし] セクションで、 [塗りつぶしの色][テーマの色 5 #6B91C9] (青) に変更します。

    Screenshot of Theme color 5.

  4. [書式] タブで、 [背面へ移動]>[最背面へ移動] を選択します。

  5. ビジュアル 1 のテキスト、タイトルを選択し、フォントの色を [白] に変更します。

ビジュアル 2 および 3 の背景図形を追加する

  1. [挿入] リボンで、 [図形]>[四角形] を選択し、それをビジュアル 2 および 3 の幅と高さに合わせて引き伸ばします。
  2. [図形の書式設定] ウィンドウの [線] セクションで、 [透明度][100%] に変更します。
  3. [塗りつぶし] セクションで、色を 10% 濃い白に設定します。
  4. [書式] タブで、 [背面へ移動]>[最背面へ移動] を選択します。

完成したレポート

最終的な洗練されたレポートは次のようになります。

Screenshot of final, formatted report.

手短に言えば、このレポートは、上司が最も関心のある質問に答えることができます。

  • 最も利益が多かったのは、どの年のどの月か?

    2014 年 12 月

  • 会社が最も成功を収めたのは、どの国/地域か?

    ヨーロッパ、特にフランスとドイツ。

  • 会社が投資を継続する必要があるのは、どの製品とセグメントか?

    会社は引き続き Paseo 製品に投資し、中小企業と政府のセグメントをターゲットにする必要があります。

レポートの保存

  • [ファイル] メニューで、 [保存] を選択します。

Power BI サービスに発行して共有する

レポートを上司や仕事仲間と共有するには、Power BI サービスに発行します。 Power BI アカウントを持っている仕事仲間と共有する場合、仕事仲間はレポートを操作できますが、変更を保存することはできません。

  1. Power BI Desktop の [ホーム] リボンで、 [発行] を選択します。

    Power BI サービスにサインインする必要がある場合があります。 まだアカウントを持っていない場合、無料試用版にサインアップできます。

  2. Power BI サービスで、[マイ ワークスペース] などの宛先 >[選択] の順に選択します。

  3. [Power BI で 'ご利用のファイル名' を開く] を選択します。

    Screenshot of opening your report in the Power BI service.

    完成したレポートがブラウザーに表示されます。

    Screenshot of your completed Power B I report in the Power B I service.

  4. レポートの上部にある [共有] を選択して、レポートを他のユーザーと共有します。

    Screenshot of sharing your report from the Power BI service.

他にわからないことがある場合は、 Power BI コミュニティをご利用ください。