警告
廃止され、サポート対象外となった Internet Explorer 11 デスクトップ アプリケーションは、特定のバージョンの Windows 10 で Microsoft Edge の更新プログラムを通じて完全に無効になります。 詳細については、「Internet Explorer 11 デスクトップ アプリの廃止に関する FAQ」をご覧ください。
この記事は、IE11 が新しいエンタープライズ モード サイトリスト XML ファイルをダウンロードできない問題を解決するのに役立ちます。
適用対象: Windows Server 2012 R2 の Internet Explorer 11、Windows 8.1 Update の Internet Explorer 11、Windows 10 の Internet Explorer 11
元の KB 番号: 4046798
症状
次のシナリオについて検討してください。
- Internet Explorer 11 のエンタープライズ モード サイト一覧を構成しました。
- Web サーバーでホストされているサイト リスト XML ファイルがある。
- 後で、Web サーバー上のサイト リスト XML ファイルを新しいバージョンに更新します。
このような状況では、次の現象が発生します。
- Internet Explorer では、サイト リスト XML ファイルの古いバージョンが引き続き使用され、更新されたサイト 一覧は Web サーバーからダウンロードされません。
- Internet Explorer は、Web サーバーから更新された XML ファイルをダウンロードするのに非常に長い時間がかかる場合があります。更新された一覧をダウンロードするには、ブラウザーキャッシュをクリアする必要があります。
原因
この問題は、Internet Explorer がキャッシュからサイト リスト XML ファイルを取得する可能性があるために発生します。 これは、標準のキャッシュ規則が原因です。
解決策
この問題を解決するには、リソースのキャッシュ動作を制御する応答ヘッダーを指定して、キャッシュの有効期間を制御します。 これを行うには、コンテンツ (サイト リスト XML ファイル) に Cache-Control:no-cache
応答ヘッダーを追加します。 これにより、コンテンツは参照されるたびにサーバーで再検証されます。
関連情報
詳細については、新しいエンタープライズ モード サイト リストの XML ファイルを確認するを参照してください。