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Internet Explorer でリンクをクリックしても何も起こりません

警告

廃止され、サポート対象外となった Internet Explorer 11 デスクトップ アプリケーションは、特定のバージョンの Windows 10 で Microsoft Edge の更新プログラムを通じて完全に無効になります。 詳細については、「Internet Explorer 11 デスクトップ アプリの廃止に関する FAQ」をご覧ください。

この記事は、Internet Explorer でハイパーリンクをクリックしたときに Web ページを開くことができない問題を解決するのに役立ちます。

元の製品バージョン: Internet Explorer 9
元の KB 番号: 175775

現象

Web ページまたは電子メール メッセージでハイパーリンクをクリックしても、何も起こりません。 Internet Explorer で Web ページが開きません。

Note

この情報は、Internet Explorer 9、Internet Explorer 8、Internet Explorer 7 に適用されます。

原因

これは、次の 1 つ以上の理由で発生する可能性があります。

  • 使用する Web ブラウザーを選択する設定が破損しています。 これにより、コンピューター上の既定のブラウザーとして設定されているブラウザーが Windows によって誤って解釈される可能性があります。
  • ソフトウェアのインストール後に設定が変更され、Web ページへのリンクが正しく機能しなくなる可能性があります。
  • 以前にインストールされたブラウザーまたはアドインが、コンピューター上の他のソフトウェアに干渉している可能性があります。
  • レジストリ キーが変更されたか、破損しました。

解決方法

このセクションは、最初から中間のコンピューター ユーザーを対象としています。 これらの方法で問題が解決しない場合は、「 Advanced troubleshooting 」セクションの方法を試すことができます。 この問題を解決するには、次のメソッドを表示順に使用します。

方法 1: 既定の Web ブラウザー設定を確認する

Microsoft Windows では、使用する Web ブラウザーを選択できます。 Internet Explorer を既定の Web ブラウザーにするには、次の手順に従います。

  1. Internet Explorer を開くには、 [スタート]ボタン、 [Internet Explorer]の順にクリックします。
  2. Internet Explorer を既定のブラウザーにするかどうかを確認するメッセージが表示されたら、[ Yes をクリックします。
  3. Tools メニューの [Internet オプション] をクリック
  4. Programs>Make default>OK をクリックし、Internet Explorer を閉じます。

Note

変更は、次回 Internet Explorer を起動するときに有効になります。

問題が解決されているかどうかを確認します。 問題が解決した場合は、この記事を完了しています。 問題が解決しない場合は、次の方法を試してください。

方法 2: Internet Explorer が既定で開くファイルの種類を変更する

Windows 7 および Windows Vista の場合。

  1. すべての Internet Explorer ウィンドウを閉じます。
  2. [スタート] ボタン、[コントロール パネル] の順にクリックします。
  3. [ Programs] をクリックし、[既定のプログラム 設定] をクリック
  4. [ Programs メニューの Internet Explorer] をクリックし、[ このプログラムの既定値を選択します
  5. .htm.html、およびurlsのチェック ボックスがオンになっていることを確認し、[ 保存] をクリック
  6. OK をクリックします。

Note

変更は、次回 Internet Explorer を起動するときに有効になります。

Windows XP の場合

  1. Windows エクスプローラーを開くには、 Start を右クリックし、[マイ コンピューター ] をクリック

  2. [ Tools メニューの Folder Options をクリックし、[ ファイルの種類 ] タブをクリックします。

  3. HTM ファイルの種類を見つけて選択します。

  4. プログラムで開くとして Internet Explorer が選択されていることを確認します。 Internet Explorer が選択されていない場合は、Change をクリックし、でコミットされたプログラムとして Internet Explorer を選択しOK をクリックします。

  5. 次のファイルの種類について、手順 3 と 4 を繰り返します。

    • HTML
    • ITS
    • MHT
    • MTHML
    • XML
    • XSL

問題が解決されているかどうかを確認します。 問題が解決した場合は、この記事を完了しています。 問題が解決しない場合は、次の方法に進みます。

方法 3: Internet Explorer のアドオンなしモードを使用する

ブラウザー アドインはオンライン エクスペリエンスを向上させることができますが、コンピューター上の他のソフトウェアに干渉したり競合したりする場合があります。 ただし、アドインが無効になっていると、一部の Web ページまたは Internet Explorer 自体が正しく表示されない場合があることに注意してください。 まず、アドインを一時的に無効にして Internet Explorer を起動し、問題が解決されたかどうかを確認します。 (通常の方法で Internet Explorer を再起動するまで、アドインは無効になります)。 これを行うには、次の手順を実行します。

  • [スタートをクリックし、Search ボックスに「Internet Explorer」と入力し、Internet Explorer (アドオンなし) をクリックします。

    Note

    Windows XP の場合は、 [スタート ] をクリックし、 Internet Explorer アイコンを右クリックし、[アドオンなしで をクリックします

Internet Explorer アドオン モードで問題が解決しない場合は、次の手順に従って、問題の原因となっているブラウザー アドインを特定します。

  1. Internet Explorer を起動するには、 Start をクリックし、 Internet Explorer をクリックします。
  2. Tools ボタンをクリックし、Manage アドオンをクリックします。
  3. [名前] リストで 追加 をクリックし、[ Disable] をクリックします。 Internet Explorer をテストします。
  4. 問題の原因となっているアドインを特定するまで、手順 3 を繰り返します。

問題が解決されているかどうかを確認します。 問題が解決した場合は、この記事を完了しています。 問題が解決しない場合は、次の方法を試してください。

方法 4: Internet Explorer の設定をリセットする

Internet Explorer の設定またはアドインが破損または互換性のない問題の原因である場合は、通常、Internet Explorer の設定を既定の設定にリセットすることで問題を解決できます。

Internet Explorer の設定をリセットすると、以前のすべての設定が失われ、回復できません。 Internet Explorer の既定の設定を復元すると、保存されている Cookie、フォーム データ、パスワード、または以前にインストールされたブラウザー アドインに依存する一部の Web ページが正しく機能しない可能性があります。 ただし、Internet Explorer を既定の設定にリセットしても、お気に入り、フィード、その他の個人用設定は削除されません。

Internet Explorer の設定をリセットするには、次の手順に従います。

  1. すべての Internet Explorer ウィンドウを閉じます。

  2. [スタートをクリックし、[検索] ボックスに「inetcpl.cpl」と入力し、[プログラム] ボックスの一覧の [inetcpl.cpl] をクリックします。 [インターネット オプション] ダイアログ ボックスが表示されます。

    Note

    Windows XP の場合は、[ 開始] をクリックし、[ 実行] をクリックし、[開く] ボックスに「 inetcpl.cpl 」と入力して、[ OK] をクリック

  3. [詳細設定] タブをクリックします。

  4. [ Internet Explorer の設定の設定で、[ Reset] をクリックします。 次に、もう一度 [ Reset をクリックします。

  5. Internet Explorer のリセットが完了したら、[Internet Explorer の設定のリセット] ダイアログ ボックスで Close をクリックします。

  6. Internet Explorer をもう一度起動します。 変更は、次回 Internet Explorer を開くと有効になります。

方法 5: 必要な Internet Explorer DLL ファイルを再登録する

Note

この情報は Windows XP に適用されます

DLL ファイルを再登録するには、次の手順に従います。

  1. [スタートをクリックし、[すべてのプログラムをクリックし、アクセスをクリックし、cmd を右クリックして、[管理者として実行] 選択します管理者のパスワードまたは確認の入力を求められた場合はpassword を入力するか確認を入力します。

  2. [開く] ボックスに「 regsvr32 urlmon.dll 」と入力し、[ OK] をクリック

  3. 確認を受け取ったら、 OK をクリックします。

  4. 次のコマンドについて、手順 2 と 3 を繰り返します。

    • regsvr32 mshtml.dll
    • regsvr32 shdocvw.dll
    • regsvr32 browseui.dll
    • regsvr32 msjava.dll

問題が解決されているかどうかを確認します。 問題が解決した場合は、この記事を完了しています。 問題が解決しない場合は、次のセクションに進みます。

高度なトラブルシューティング

このセクションは、より高度なコンピューター ユーザーを対象としています。

方法 1: 新しいユーザー アカウントを作成する

ユーザー プロファイルの詳細については、「 ユーザー プロファイルについてを参照してください。

メソッドの詳細については、次の Microsoft Web サイトを参照してください。

方法 2: システムの復元を使用する

システム復元では、 ストア ポイント を使用して、個人用ファイルに影響を与えることなく、システム ファイルと設定を以前の時点に戻します。 復元ポイントは、プログラム、デバイス、ドライバーのインストールなど、重要なシステム イベントの直前に毎週自動的に作成されます。

システムの復元を開始する前に、開いているファイルを保存し、すべてのプログラムを閉じます。 復元ポイントを確認すると、システムの復元によってコンピューターが再起動されます。 システム復元を実行するには、次の手順に従います。

Windows 7 および Windows Vista の場合

  1. [スタート] をクリックし、[すべてのプログラム] をクリックし[アクセス]、[システム ツール]、[システムの復元] の順にクリック管理者のパスワードまたは確認の入力を求められた場合はpassword を入力するか確認を入力します。

  2. [システムの復元] ページ [次へ ] をクリックします。

  3. システムの復元日または指定を選択します。

    Note

    探している特定の日付が表示されない場合は、[その他の日付を表示] を選択し、目的の日付を選択します。

  4. 確認ウィンドウで、[ Finish をクリックします。 コンピューターが再起動します。 プロセスが完了すると、確認メッセージが表示されます。

Windows XP の場合

  1. 管理アクセス許可を持つアカウントを使用して Windows にログオンします。
  2. [スタート] をクリックし、[すべてのプログラム] をクリックし[アクセス]、[システム ツール]、[システムの復元] の順にクリック
  3. [システムの復元へようこそ] ページで、 コンピューターを以前の時刻に復元する] オプションを選択し [次へ ] をクリック
  4. 復元ポイントの選択ページで、最近のシステムの復元ポイントをクリックしこの一覧で復元ポイントの一覧をクリックし、 次へをクリックします。
  5. [復元ポイントの選択ページで、[次へ] をクリック。 システムの復元は、以前の Windows XP 構成を復元し、コンピューターを再起動します。
  6. 管理者としてコンピューターにログオンします。 次に、システム復元の完了ページ OK をクリックします。 コンピューターが再起動します。 プロセスが完了すると、確認メッセージが表示されます。

システム復元を使用しても問題が発生した場合、またはその他の問題が発生した場合は、復元操作を元に戻すことができます。 操作を元に戻した後は、別の復元ポイントを使用してみます。 システムの復元操作を元に戻すには、次の手順に従います。

  1. [スタート] をクリックし、[すべてのプログラム] をクリックし[アクセス]、[システム ツール]、[システムの復元] の順にクリック
  2. [システムの復元 を行う] をクリックし、[次へ ] をクリック
  3. 選択内容を確認し、[ Finish] をクリックします。

コンピューターが再起動します。 プロセスが完了すると、確認メッセージが表示されます。

その他のリソース

問題が解決されているかどうかを確認します。 問題が解決した場合は、この記事を完了しています。 問題が解決しない場合は、Microsoft カスタマー サポート サービスを使用して他の解決策を見つけることもできます。 Microsoft サポート サービスには、次の方法があります。