Internet Explorer でリンクをクリックしても何も起こらない
警告
廃止され、サポート対象外となった Internet Explorer 11 デスクトップ アプリケーションは、特定のバージョンの Windows 10 で Microsoft Edge の更新プログラムを通じて完全に無効になります。 詳細については、「Internet Explorer 11 デスクトップ アプリの廃止に関する FAQ」をご覧ください。
この記事は、Internet Explorer でハイパーリンクをクリックしても Web ページを開くことができないという問題の解決に役立ちます。
元の製品バージョン: Internet Explorer 9
元の KB 番号: 175775
現象
Web ページまたは電子メール メッセージのハイパーリンクをクリックしても、何も起こりません。 Internet Explorer で Web ページが表示されません。
Note
この情報は、Internet Explorer 9、Internet Explorer 8、Internet Explorer 7 に適用されます。
原因
この現象は、以下のいずれかまたは複数の原因によって発生する可能性があります。
- 使用する Web ブラウザーを選択した場所で設定が破損している。 このため、Windows では、コンピューターの既定のブラウザーとして設定されているブラウザーが正しく解釈されない可能性があります。
- ソフトウェアのインストール後、設定が変更され、これが原因で Web ページへのリンクが正常に機能しない。
- 以前にインストールしたブラウザーまたはアドインがコンピューター上の他のソフトウェアに干渉している。
- レジストリ キーが変更されたか、破損した。
解決方法
このセクションは初級レベルから中級レベルのコンピューター ユーザーを対象にしています。 これらの方法を使用しても問題が解決しない場合は、「高度なトラブルシューティング」セクションに記載されている方法を試すことができます。 この問題を解決するには、以下の方法を記載されている順に使用します。
方法 1: 既定の Web ブラウザーの設定を確認する
Microsoft Windows では、使用する Web ブラウザーを選択できます。 Internet Explorer を既定のブラウザーにするには、以下の手順を実行します。
- Internet Explorer を開くには、[スタート] ボタンをクリックし、[Internet Explorer] をクリックします。
- Internet Explorer を既定のブラウザーにすることを確認するメッセージが表示された場合は、[はい] をクリックします。
- [ツール] メニューの [インターネット オプション] をクリックします。
- [プログラム]>、[既定にする]>、[OK] の順にクリックし、Internet Explorer を閉じます。
Note
次回 Internet Explorer を起動したときに、変更内容が有効になります。
問題が解決されたかどうかを確認します。 問題が解決された場合、この資料の作業は完了していることになります。 問題が解決していない場合は、次の方法を試します。
方法 2: Internet Explorer が既定で開くファイルの種類を変更する
Windows 7 と Windows Vista の場合。
- すべての Internet Explorer ウィンドウを閉じます。
- [スタート] ボタン、[コントロール パネル] の順にクリックします。
- [プログラム] をクリックし、[既定のプログラムの設定] をクリックします。
- [プログラム] メニューの [Internet Explorer] をクリックし、[既定でこのプログラムで開く項目を選択する] (Windows Vista では [このプログラムの既定を選択する]) をクリックします。
.htm
、.html
、urls
のチェックボックスがオンになっていることを確認してから、[保存] をクリックします。- [OK] をクリックします。
Note
次回 Internet Explorer を起動したときに、変更内容が有効になります。
Windows XP の場合
エクスプローラーを開くには、[スタート] ボタンを右クリックし、[マイ コンピューター] をクリックします。
[ツール] メニューの [フォルダー オプション] をクリックし、[ファイルの種類] タブをクリックします。
HTM のファイルの種類を探して選択します。
Internet Explorer が [プログラムで開く] として選択されていることを確認します。 Internet Explorer が選択されていない場合は、Change をクリックし、でコミットされたプログラムとして Internet Explorer を選択しOK をクリックします。
以下のファイルの種類に対して、手順 3. および 4. を繰り返します。
HTML
ITS
MHT
MTHML
XML
XSL
問題が解決されたかどうかを確認します。 問題が解決された場合、この資料の作業は完了していることになります。 問題が解決していない場合は、次の方法に進みます。
方法 3: Internet Explorer のアドオンなしモードを使用する
ブラウザーのアドインは、オンラインでの操作を向上させることができますが、場合によってはコンピューター上の他のソフトウェアと干渉または競合する可能性があります。 ただし、アドインが無効である場合、一部の Web ページまたは Internet Explorer 自体が正しく表示されないことがある点に注意してください。 まず、アドインを一時的に無効にして Internet Explorer を起動し、問題が解決されたかどうかを確認します (アドインが無効になるのは、通常の方法で Internet Explorer を再起動するまでに限定されます)。 これを行うには、次の手順を実行します。
[スタート] ボタンをクリックし、検索ボックスに「Internet Explorer」と入力し、[Internet Explorer (アドオンなし)] をクリックします。
Note
Windows XP の場合は、[スタート] をクリックし、Internet Explorer アイコンを右クリックして、[アドオンなしで参照] をクリックします。
Internet Explorer のアドオンなしモードで問題が解決した場合は、次の手順を実行して、問題の原因となっているブラウザー アドインを特定します。
- Internet Explorer を起動するには、[スタート] ボタンをクリックし、[Internet Explorer] をクリックします。
- [ツール] ボタンをクリックし、[アドオンの管理] をクリックします。
- [名前] 一覧で [アドイン] をクリックし、[無効にする] をクリックします。 Internet Explorer のテストを行います。
- 手順 3 を繰り返して、問題の原因となっているアドインを特定します。
問題が解決されたかどうかを確認します。 問題が解決された場合、この資料の作業は完了していることになります。 問題が解決していない場合は、次の方法を試します。
方法 4: Internet Explorer の設定をリセットする
Internet Explorer の設定またはアドインが破損したか互換性がないことが原因で問題が発生している場合、通常は Internet Explorer の設定を既定の設定にリセットすることで問題を解決できます。
Internet Explorer の設定をリセットすると、以前の設定はすべて失われ、回復することはできません。 Internet Explorer の既定の設定を復元すると、保存されている Cookie、フォーム データ、パスワード、または以前にインストールされたブラウザー アドインに依存する一部の Web ページは正常に機能しない場合があります。 ただし、Internet Explorer を既定の設定にリセットしても、お気に入り、フィード、その他の一部の個人設定は削除されません。
Internet Explorer の設定をリセットするには、以下の手順を実行します。
すべての Internet Explorer ウィンドウを閉じます。
[スタート] をクリックし、検索ボックスに「inetcpl.cpl」と入力して、[プログラム] 一覧の [inetcpl.cpl] をクリックします。 [インターネット オプション] ダイアログ ボックスが表示されます。
Note
Windows XP の場合は、[スタート] をクリックし、[実行] をクリックし、[開く] ボックスに「inetcpl.cpl」と入力して、[OK] をクリックします。
[詳細設定] タブをクリックします。
[Internet Explorer の設定をリセットします] で、[リセット] をクリックします。 もう一度 [リセット] をクリックします。
Internet Explorer でリセットが完了したら、[Internet Explorer の設定をリセット] ダイアログ ボックスで [閉じる] をクリックします。
Internet Explorer を再起動します。 次回 Internet Explorer を起動するときに、変更内容が有効になります。
方法 5: 必要な Internet Explorer の DLL ファイルを再登録する
Note
この情報は Windows XP に適用されます
DLL ファイルを再登録するには、次の手順を実行します。
[スタート] をクリックし、[すべてのプログラム]、[アクセサリ] の順にクリックし、[cmd] を右クリックして、[管理者として実行] を選択します。 管理者パスワードまたは確認を要求するダイアログ ボックスが表示された場合は、パスワードを入力するか、確認を実行してください。
[名前] ボックスに「regsvr32 urlmon.dll」と入力し、[OK] をクリックします。
確認のメッセージが表示されたら、[OK] をクリックします。
以下のコマンドに対して手順 2. と 3. を繰り返します。
regsvr32 mshtml.dll
regsvr32 shdocvw.dll
regsvr32 browseui.dll
regsvr32 msjava.dll
問題が解決されたかどうかを確認します。 問題が解決された場合、この資料の作業は完了していることになります。 問題が解決していない場合は、次のセクションに進みます。
高度なトラブルシューティング
以下の説明は、上級レベルのコンピューター ユーザーを対象としています。
方法 1: ユーザー アカウントを新規作成する
ユーザー プロファイルの詳細については、「ユーザー プロファイルとは」を参照してください。
方法の詳細については、以下のマイクロソフト Web サイトを参照してください。
方法 2: システムの復元を使用する
システムの復元では、復元ポイントを使用して、個人用ファイルに影響を与えることなくシステム ファイルと設定を以前の時点に戻します。 復元ポイントは毎週自動的に作成されます。またプログラム、デバイス、またはドライバーなどのインストールなど、重要なシステム イベントの直前にも作成されます。
システムの復元を開始する前には、開いてあるすべてのファイルを保存し、すべてのプログラムを終了します。 復元ポイントを確認したら、システムの復元によりコンピューターが再起動されます。 システムの復元を実行するには、以下の手順を実行します。
Windows 7 および Windows Vista の場合
[スタート] ボタンをクリックし、[すべてのプログラム]、[アクセサリ]、[システム ツール]、[システムの復元] の順にクリックします。 管理者パスワードまたは確認を要求するダイアログ ボックスが表示された場合は、パスワードを入力するか、確認を実行してください。
[システムの復元] ページで [次へ] をクリックします。
必要なシステムの復元日または説明を選択します。
Note
探している特定の日付が表示されない場合は、[さらに日付を表示] を選択してから、目的の日付を選択します。
確認ウィンドウで [完了] をクリックします。 コンピューターを再起動します。 処理が完了したら、確認メッセージが表示されます。
Windows XP の場合
- 管理者のアクセス許可を持つアカウントを使用して、Windows にログオンします。
- [スタート] ボタンをクリックし、[すべてのプログラム]、[アクセサリ]、[システム ツール]、[システムの復元] の順にクリックします。
- [システムの復元の開始] ページで、[コンピューターを以前の状態に復元する] オプションをオンにして、[次へ] をクリックします。
- 復元ポイントの選択ページで、最近のシステムの復元ポイントをクリックしこの一覧で復元ポイントの一覧をクリックし、 次へをクリックします。
- [復元ポイントの選択の確認] ページで [次へ] をクリックします。 システムの復元により、以前の Windows XP 構成に復元され、コンピューターが再起動されます。
- 管理者としてコンピューターにログオンします。 システムの復元の [復元は完了しました] ページで [OK] をクリックします。 コンピューターを再起動します。 処理が完了したら、確認メッセージが表示されます。
システムの復元を使用したが、問題が依然として発生する場合や、他の問題が発生した場合は、復元の操作を取り消すことができます。 操作を取り消した後は、別の復元ポイントを試すことができます。 システムの復元の操作を取り消すには、以下の手順を実行します。
- [スタート] ボタンをクリックし、[すべてのプログラム]、[アクセサリ]、[システム ツール]、[システムの復元] の順にクリックします。
- [システムの復元の取り消し] をクリックし、[次へ] をクリックします。
- 選択内容を確認し、[完了] をクリックします。
コンピューターを再起動します。 処理が完了したら、確認が表示されます。
その他のリソース
問題が解決されたかどうかを確認します。 問題が解決された場合、この資料の作業は完了していることになります。 問題が解決されなかった場合は、Microsoft Customer Support Services を使用して他の解決策を検索することもできます。 Microsoft サポート サービスでは、以下のような方法を利用できます。
- サポート技術情報の検索: マイクロソフト製品に関するテクニカル サポート情報とセルフ サポート ツールを検索できます。
- ソリューション センター: よく寄せられる質問と重要なサポート情報を製品別に参照できます。
- マイクロソフト コミュニティ: 他のユーザーやマイクロソフト MVP (Most Valuable Professionals) から情報を得ることができます。
- その他のサポート オプション: 質問したり、Microsoft Customer Support Services に問い合わせたり、フィードバックを送信したりできます。