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アクセス許可のため、電子メール ルーターが Microsoft Dynamics から電子メールを送信できない

この記事では、電子メール ルーターがアクセス許可のために Microsoft Dynamics から電子メールを送信できない問題の解決策を示します。

適用対象: Microsoft Dynamics 365 Customer Engagement Online
元の KB 番号: 4494727

症状

Dynamics 365 電子メール ルーターを使用して Dynamics 365 インスタンスから電子メールを送信する場合、電子メールは保留中の送信状態になり、実際には送信されないことがあります。

[保留中の送信] 状態の電子メールを示すスクリーンショット。

Dynamics 電子メール ルーターの例外ログには、次のエラーが表示される場合があります。

処理する送信電子メール メッセージのチェック中にエラーが発生しました: https://disco.crm.dynamics.com/\<OrgName>。 System.ServiceModel.FaultException'1[Microsoft.Xrm.Sdk.OrganizationServiceFault]: ユーザーに送信権限がありません。 (エラーの詳細は例外の詳細と同じです。

ErrorCode: 0x8004480D
メッセージ: ユーザーに送信権限がありません。

原因

この動作は、以前のバージョンの Dynamics 365 アプリケーションでこれらのアクセス許可を必要とせずに動作した可能性があります。 バージョン 8.2.2 および 9.x の特定のイテレーションでセキュリティ モデルが変更されたため、電子メール ルーターが別のユーザーの電子メールを送信するには、これらのアクセス許可を明示的に付与する必要があります。

解決方法

このメールを送信するユーザーは、個人用オプションで他の Dynamics ユーザーから電子メールを送信できるようにする必要があります。

[他の Microsoft Dynamics 365 ユーザーがユーザーに代わって電子メールを送信することを許可する] オプションを選択するスクリーンショット。

電子メール ルーターで使用されているアカウントには、Dynamics 内の Send Email as another User アクセス許可も必要です。

「別のユーザーとして電子メールを送信する」アクセス許可のスクリーンショット。

詳細