この記事では、Microsoft Dynamics CRM 構成ウィザードの Outlook プロファイルの読み込み中にエラー メッセージが表示される可能性がある問題の解決策について説明します。
適用対象: Microsoft Dynamics CRM 2011
元の KB 番号: 2538692
症状
Microsoft Dynamics CRM 2011 Outlook クライアントを構成するときに、ユーザーの Windows Live ID を入力した後、および構成ウィザードの Outlook プロファイルの読み込み中にエラーが発生します。
Crm50ClientConfig.logでは、次のエラーが発生します。
エラー|例外: at Microsoft.Interop.Mapi.CRcwMsgServiceAdmin.CreateMsgServiceEx(String ServiceName, String DisplayName, IntPtr UIParam, IMsgServiceAdmin_CreateMsgService_Flags Flags)
at Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.InstallCrmDatastore(Guid organizationId, Guid userId, String serverUrl, String organizationName, String displayName)
Microsoft.Crm.Application.Outlook.Config.OutlookConfiguratorで構成を行う際に進行イベントハンドラー(IProgressEventHandler progressEventHandler)を使用します。
Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)で
Crm50ClientConfig.logは、次のディレクトリにあります。
Windows7/2008
%userprofile%\AppData\Local\Microsoft\MSCRM\Logs
WindowsXP/2003
%userprofile%\Local Settings\Application Data\MSCRM\Logs
原因
上記のエラーは、次のいずれかの条件に該当する場合に発生する可能性があります。
原因 1:
MAPISVC.inf ファイルが適切な場所に存在しません。
原因 2:
Microsoft Dynamics CRM サービスが MAPISVC.inf ファイルに登録されていません
解決方法
解決策 1:
MAPISVC.inf ファイルの場所は、Windows と Outlook のアーキテクチャの種類によって異なります。 Windows と Outlook のアーキテクチャの種類に基づいて MAPISVC.inf ファイルが存在する必要がある場所を次に示します。
32 ビットまたは x86 バージョンの Windows および Outlook:
C:\Windows\System32\mapisvc.inf
C:\Program Files\Common Files\System\MSMAPI\1033\mapisvc.inf
64 ビットまたは x64 バージョンの Windows および Outlook:
C:\Program Files\Common Files\System\MSMAPI\1033\mapisvc.inf
C:\windows\SysWOW64\mapisvc.inf
32 ビットまたは x86 バージョンの Outlook と 64 ビットまたは x64 バージョンの Windows:
C:\Program Files (x86)\Common Files\System\MSMAPI\1033\mapisvc.inf
C:\windows\SysWOW64\mapisvc.inf
MAPISVC.inf ファイルが次のいずれかの場所に存在しない場合は、UserProfile で探してみてください。
Windows7/2008
%userprofile%\AppData\Local\Microsoft\Outlook
WindowsXP/2003
%userprofile%\Local Settings\Application Data\Microsoft\Outlook
MAPISVC.inf ファイルが UserProfile に存在する場合は、Windows と Outlook のアーキテクチャの種類に基づいて適切なディレクトリにコピーします。
Windows または Outlook で使用しているアーキテクチャの種類がわからない場合は、次の手順を使用します。
ウィンドウズ:
[Windows/スタート] ボタンを選択します。
Programs>Accessories に移動します。
コマンド プロンプトを右クリックし、 管理者として実行を選択します。
次のコマンドを実行します。
reg query "HKLM\System\CurrentControlSet\Control\Session Manager\Environment" /V PROCESSOR_ARCHITECTURE
返された場合、次の結果は、オペレーティング システムが 64 ビット オペレーティング システムであることを示します。
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment
PROCESSOR_ARCHITECTURE REG_SZ AMD64
返された場合、次の結果は、オペレーティング システムが 32 ビットオペレーティング システムであることを示します。
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment
PROCESSOR_ARCHITECTURE REG_SZ x86
Windows が 32 ビット オペレーティング システムの場合、Outlook は 32 ビット アプリケーションになります。 ただし、Windows が 64 ビット オペレーティング システムの場合、Outlook は 32 ビット アプリケーションまたは 64 ビット アプリケーションのいずれかになります。 Outlook 2003 および Outlook 2007 は、32 ビット アプリケーションとしてのみサポートされています。 ただし、Outlook 2010 には次の両方のアーキテクチャの種類があります。
Outlook 2010 のバージョンを確認するには、次の手順に従います。
[Windows/スタート] ボタンを選択します。
Programs>Accessories に移動します。
コマンド プロンプトを右クリックし、 管理者として実行を選択します。
Office のバージョンに基づいて次のコマンドを実行します。
reg query "HKLM\Software\Microsoft\Office\14.0\Outlook" /V Bitness
解決策 2:
Microsoft Dynamics CRM サービスが MAPISVC.inf ファイルに登録されていない場合は、これらのエントリを MAPISVC.inf ファイルに手動で追加し、適切な場所に配置できます。
この問題に対処するには、Microsoft Dynamics CRM サポートにお問い合わせください。
詳細
問題が解決されたかどうかを確認します。 問題が解決された場合、このセクションの作業は完了していることになります。 問題が解決しない場合は、Microsoft サポートにお問い合わせください。