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すみません。 サーバーが使用できないか、このアプリケーションをサポートしていません。 iPad または iPhone で CRM アプリに接続するときにエラーが発生する

この記事では、iPhone または iPad を Dynamics CRM アプリに接続するときに発生するエラーの解決策について説明します。

適用対象: Microsoft Dynamics CRM 2013、Microsoft Dynamics CRM 2015
元の KB 番号: 3069747

症状

iPhone または iPad を Dynamics CRM アプリに接続しようとすると、次のエラーが表示されることがあります。

" 申し訳ございません。 サーバーが使用できないか、このアプリケーションをサポートしていません。

原因

一部の外部証明機関によって生成された SSL 証明書では、iPhone または iPad で CRM アプリを構成するときに、証明書チェーン全体が信頼されるという問題が発生する可能性があります。

詳細

Web アプリケーションを介して Microsoft Dynamics CRM サイトにアクセスすると、正しく機能します。 ただし、iOS デバイスでは、AD FS と CRM 用に構成された SSL 証明書が信頼されていないと見なされる場合があります。 UIWebViews と WKWebViews を使用して Web ページをレンダリングする iOS アプリを使用すると、同様の証明書関連のエラーが表示されます。

iOS デバイスログには、次の情報が表示されます。

認証: 認証が中断されました。

SSL 証明書がドメイン全体 ( *.contoso.com など) のワイルドカード証明書である場合に発生しました。 https://contoso.comなどのルート ドメインが正しく機能します。 https://crm.contoso.comなどのサブドメインは期待どおりに機能しません。 これは、ワイルドカードサブジェクトの別名を一覧表示するiOSデバイスおよび証明書との互換性が原因である可能性があります。 ルート レベルに CRM サブドメイン ( *.crm.domain.comなど) が含まれる証明書を使用してテストすることをお勧めします。