次の方法で共有


Microsoft Dynamics 365 でサーバー側同期を使用すると、Http サーバーから 404 NotFound 例外が返されました

この記事では、Microsoft Dynamics 365 でメールボックスをテストして有効にしようとしたときに発生する可能性があるエラー メッセージを解決するための解決策について説明します。

適用対象: Microsoft Dynamics C5 2016
元の KB 番号: 3214661

症状

Microsoft Dynamics 365 (旧称 Microsoft Dynamics CRM Online) でメールボックスをテストして有効にすると、[アラート] 領域で次のいずれかのエラーが発生します。

  • メール サーバーへの接続中にエラーが発生したため、メールボックス <Mailbox 名> が同期しませんでした。 関連付けられた電子メール サーバー プロファイル <電子メール サーバー プロファイル名> の所有者に通知されました。
  • メールボックス <Mailbox 名> は、Microsoft Exchange サーバーへの接続中にエラーが発生したため、予定、連絡先、タスクを同期しませんでした。 関連付けられた電子メール サーバー プロファイル <電子メール サーバー プロファイル名> の所有者に通知されました。
  • 電子メール サーバーへの接続中にエラーが発生したため、電子メール メッセージのテスト メッセージ を送信できません。 メールボックス <メールボックス名> は同期されませんでした。 関連付けられた電子メール サーバー プロファイル <電子メール サーバー プロファイル名> の所有者に通知されました。

上記の各エラーには、次のエラー コードも含まれています。

電子メール サーバーエラー コード: Http サーバーから 404 NotFound 例外が返されました。

原因

このエラーは、次のいずれかの理由で発生することがあります。

  1. メール アドレスが正しくないか、メールボックスが現在使用できないため、ユーザーのメールボックスが見つかりませんでした。
  2. 関連付けられている電子メール サーバー プロファイルの構成が、メールボックスを見つけられるように正しく構成されていません。

解決方法

この問題を解決するには、次の手順に従います。

  1. Microsoft Dynamics 365 のメールボックス レコードの電子メール アドレスが Exchange の電子メール アドレスと一致するかどうかを確認します。 このエラーには、Microsoft Dynamics 365 のメールボックス レコードへのリンクが含まれています。 このリンクを使用すると、[ 電子メール アドレス] フィールドをすばやく確認できます。 メール アドレスが正しい場合は、Microsoft Outlook や Outlook Web Access などのメール アプリケーションでメールボックスを開いて、メールボックスが使用可能であることを確認します。
  2. 関連付けられている電子メール サーバー プロファイルの構成を確認します。 オンプレミスの Exchange で Microsoft Dynamics 365 (オンライン) を使用している場合は、Exchange Server (ハイブリッド) 電子メール サーバー プロファイルを使用していることを確認してください。 Exchange Online のメールボックスを持つユーザーにのみ Exchange Online プロファイルを使用します。

詳細

[ 詳細の表示] を選択すると、次のようなエラーの詳細が表示されます。

アクティビティID: <GUID>
エラー : System.Net.WebException: HTTP 状態 404: Not Found で要求が失敗しました。
System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) において
System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult) メソッドの呼び出しが終了しました。
で、Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindItem(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.FindItemsStep.EndCall()
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()

アクティビティID: <GUID>
エラー : System.Net.WebException: HTTP 状態 404: Not Found で要求が失敗しました。
System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) において
System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult) メソッドの呼び出しが終了しました。
マイクロソフト.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)で
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

T:593
アクティビティID: <GUID>
例外: ハンドルされない例外: Microsoft.Exchange.WebServices.Data.ServiceRequestException: 要求が失敗しました。 リモート サーバーがエラー (404) Not Found を返しました。
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.EndGetEwsHttpWebResponse(IEwsHttpWebRequest request, IAsyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.SimpleServiceRequestBase.EndInternalExecute(IAsyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest'1.EndExecute(IAsyncResult asyncResult)
at Microsoft.Exchange.WebServices.Data.ExchangeService.EndSyncFolderHierarchy(IAsyncResult asyncResult)
別のメール同期操作の終了時に at Microsoft.Crm.Asynchronous.EmailConnector.MonitoredExchangeService.EndSyncFolderHierarchy(IAsyncResult asyncResult)
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.ExchangeSyncAsyncRemoteStep'2.AfterCall()
at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeSyncSteps.ExchangeSyncAsyncRemoteStep'2.E..