元の KB 番号: 2497077
症状
Microsoft Office Outlook 2007、Outlook 2010、または Outlook 2013 を使用して、Microsoft Exchange Server 2007、Exchange Server 2010、または Exchange Server 2013 でグローバル アドレス一覧 (GAL) 内のユーザーを検索すると、次の問題が発生する可能性があります。
- Outlook アドレス帳の高度な検索で [表示名] フィールドを使用して検索結果を並べ替えるオプションを選択した場合、結果は [表示名] 列を使用して並べ替えられません。
- ユーザー名または配布リスト名を持つオブジェクトを検索する場合、 [名前のみ] オプションが有効になっている場合、検索操作は正しいオブジェクトを返しません。
注意
[その他の列]オプションが有効になっている場合、検索操作は正しい結果を返します。
原因
この問題は、Active Directory ドメイン Services (AD DS) が Windows Server 2008 のインデックス作成にふりがなを使用しているために発生します。
Windows Server 2008 の AD DS でふりがなの表示名をユーザーまたは配布グループ オブジェクトに設定すると、グローバル カタログ サーバーでふりがな表示名のインデックスが生成されます。 インデックスは、日本語バージョンの Outlook で GAL の検索結果を検索または配置するために使用されます。 GAL 内のオブジェクトにふりがな表示名がない場合、表示名はインデックス作成に使用されます。 [名前のみ]オプションが選択されている場合、検索範囲はふりがなの表示名を持つオブジェクトに制限されます。 したがって、オブジェクトにふりがなの表示名がない場合、Office Outlook でアドレス帳を検索すると、正しくない結果が表示されます。
たとえば、一部のオブジェクトにふりがなの表示名がない GAL で、ふりがなの表示名とは異なる表示名を検索します。 このシナリオでは、 [表示名] 列に一致する表示名を持つオブジェクトは検索結果に返されず、ふりがなの表示名を持つオブジェクトのみが返されます。
GAL 上のすべてのユーザーと配布リストのふりがなの表示名が設定されていない場合、 [名前のみ] オプションを使用する検索は正しい結果を返します。 ふりがなの表示名のインデックスには表示名のみが含まれているため、正しい結果が返されます。
回避策
重要
このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 したがって、次の手順を注意深く実行してください。 保護のために、レジストリを変更する前に、バックアップします。 その後、問題が起こった場合は、レジストリを復元できます。 レジストリをバックアップおよび復元する方法の詳細については、次の記事の番号をクリックして表示される Microsoft サポート技術情報の記事を参照してください。
322756 Windows でレジストリをバックアップおよび復元する方法
この問題を回避するには、以下のいずれかの方法を使用します。
方法 1 を使用してこの問題を解決するには、「自分で修正する」セクションに進んでください。
自分で解決する
方法 1
- [ Start
] をクリックし、 Run をクリックし、「 Regedit」と入力して、 OK キーを押します。
- 次のレジストリ サブキーのいずれかで DisableGALPhonetic レジストリ エントリを見つけてクリックします。
HKEY_CURRENT_USER\Software\Policies\Microsoft\Exchange\Exchange Provider
HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider
注意
DisableGALPhonetic レジストリ エントリが存在しない場合は、このエントリを作成する必要があります。 これを行うには、次の手順を実行します。
- [ Edit ] メニューの [ New] をクリックし、[ DWORD(32 ビット) 値をクリックします。
- 「 DisableGALPhonetic」と入力し、Enter キーを押します。
- DisableGALPhoneticを右クリックし、[Modify] をクリックし、[値のデータ] ボックスに「1」と入力して、[OK] をクリックします。
- レジストリ エディターを終了し、コンピューターを再起動して変更を適用します。
- [ Start
方法 2
GAL でふりがなを持つオブジェクトとふりがなを持たないオブジェクトを検索する場合は、[名前のみ] オプションの代わりに、[その他の列] オプションを使用します。
これで問題が解決しましたか?
問題が解決されたかどうかを確認します。 問題が解決した場合は、このセクションを完了します。 問題が解決しない場合は、サポートに連絡できます。
詳細
Outlook クライアントは、Exchange Server 2010 組織のクライアント アクセス サーバー (CAS) に接続します。 ただし、Exchange Server 2010 RTM の Outlook で GAL を検索または表示する場合、CAS はふりがなのインデックスをサポートしていません。 キャッシュされていないモードを使用して Office Outlook でアドレス一覧を検索する場合、一致するユーザーは検索結果に返されません。 ただし、アドレス一覧の一番下のオブジェクトが選択されています。 この問題を解決するには、Exchange Server 2010 Service Pack 1 (SP1) をインストールします。