Azure Virtual Desktop ユーザーは、黒い画面になるサインインの問題が発生する可能性があります。 黒い画面には複数の原因が考えられますが、ユーザーは AppReadiness との同期に関する問題や、複数のセッションのサインインまたはサインアウトの影響を受ける可能性があります。
注記
これらのサインインの問題は、RDS 環境でも発生する可能性があります。この環境では、ユーザー プロファイルがサインインするたびに作成され、すべてのサインアウトが削除されます。
原因
次の一覧には、黒い画面を引き起こす既知のシナリオと、それらに対処するセキュリティ以外の修正プログラムが含まれています。 このリストでは、黒い画面が発生する可能性のあるすべての理由が説明されているわけではありません。 最新のアップデートがインストールされていることを確認してください。画面が空白になる問題を修正するアップデートがほぼ毎月リリースされています。
解決方法
注記
回避策は、長期的な解決策とは見なさないでください。 変更をテストするたびにレジストリ キーをバックアップします。 黒い画面が AppReadiness の問題に関連付けられている場合は、 AppReadiness のシェル前タスクに次のレジストリ エントリを設定し、最初のユーザーのサインインの黒い画面を回避するために、最初のサインインのタイムアウト ウィンドウを 30 秒に変更します。
レジストリの場所 | データ型 | 価値 | 新しいタイムアウト期間 |
---|---|---|---|
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\AppReadinessPreShellTimeoutMs |
データ型: DWORD |
値: 0x7530 |
30000 ミリ秒 = 30 秒 |
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\FirstLogonTimeout |
データ型: DWORD |
値: 0x1e |
30000 ミリ秒 = 30 秒 |
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\DelayedDesktopSwitchTimeout |
データ型: DWORD |
値: 0x1e |
30000 ミリ秒 = 30 秒 |
その他の情報
最新の更新プログラムがあることを確認した後も黒い画面が表示され続ける場合は、 フル メモリ ダンプを実行し サポート ケースに含めます。