Share via


バージョン情報とログはどこにありますか

枠線

バージョン情報

通常は、[情報のコピー] ボタンからすべての情報を返すことが最も適切です。 そうでないと、多くの場合、追加情報を要求する必要が生じます。 たとえば、オペレーティング システムのバージョン、Xcode のバージョン、インストール済みの Android API のレベル、.NET のバージョンはすべて、問題のトラブルシューティングを実行しやすくするために重要であると考えられます。

Windows のバージョン情報

Xamarin Studio

[ヘルプ] > [バージョン情報] > [詳細を表示] > [情報のコピー] [ボタン]

Visual Studio

[ヘルプ] > [About Microsoft Visual Studio] (Microsoft Visual Studio のバージョン情報) > [情報のコピー] [ボタン]

Mac のバージョン情報

Visual Studio for Mac

[Visual Studio] > [About Visual Studio] (Visual Studio のバージョン情報) > [詳細を表示] > [情報のコピー] [ボタン]

Android SDK Tools、プラットフォーム ツール、ビルド ツール

Android SDK マネージャーを開き、上部の [ツール] セクションのスクリーンショットを撮ります。

Visual Studio for Mac

[ツール] > [Android SDK マネージャーを開く]

Visual Studio

[ツール] > [Android] > [Android SDK マネージャーを開く]

IDE とインストーラーのログ

ログの場所ごとに、ログ フォルダー全体を zip で圧縮して添付します。

Windows ログ

Xamarin 用の Visual Studio ツール

%LOCALAPPDATA%\Xamarin\Logs

Visual Studio 2017

Visual Studio のインストール ログを取得する方法

Visual Studio 2015

Xamarin "ユニバーサル" インストーラー

%LOCALAPPDATA%\Xamarin\Universal

これらは XamarinInstaller.exe インストーラーからのログです。

個別の .msi インストーラー、詳細ログ

msiexec /i Xamarin.msi /l*vx "%USERPROFILE%\Desktop\Xamarin.log"

リファレンス: コマンド ライン オプション

Visual Studio の起動、詳細ログ

devenv.exe /log "%USERPROFILE%\Desktop\VisualStudio.log"

リファレンス: /Log (devenv.exe)

Mac ログ

Finder で [移動] > [フォルダーに移動] メニュー項目を選択してから、これらのパスの任意のものをコピーしてダイアログに貼り付けることができます。

Visual Studio for Mac

~/Library/Logs/VisualStudio/7.0 (この数値は、使用しているバージョンによって変わる場合があります)

このフォルダーは、"[ヘルプ] -> [ログ ディレクトリを開く]" を使用して開くこともできます。

Xamarin Studio

~/Library/Logs/XamarinStudio-6.0 (この数値は、使用しているバージョンによって変わる場合があります)

このフォルダーは、"[ヘルプ] -> [ログ ディレクトリを開く]" を使用して開くこともできます。

Xamarin "ユニバーサル" インストーラー

~/Library/Logs/XamarinInstaller/Universal

これらは XamarinInstaller.dmg インストーラーからのログです。

Xamarin ビルド ホスト

~/Library/Logs/Xamarin-[MAJOR.MINOR]

詳細なビルド出力

  1. 診断用 MSBuild 出力を有効にします。

  2. iOS アプリの場合は、[プロジェクトのプロパティ] > [iOS ビルド] > [全般] (タブ) > [その他のオプション] > [その他の mtouch 引数]-v -v -v -v を追加して、詳細な mtouch 出力も有効にします。

  3. プロジェクトをクリーンアップしてリビルドします。

  4. IDE のビルド出力をコピーしてテキスト ファイルに貼り付けます。

    • Visual Studio (Windows): [表示] > [出力] > [Show output from: Build] (ビルドから出力を表示する)
    • Visual Studio for Mac: [表示] > [Pads] (パッド) > [エラー] > [ビルド出力] (タブ)

Xamarin.Android および Xamarin.iOS アプリのデバッグ ログ

Visual Studio for Mac

[表示]> [Pads] (パッド) > [アプリケーション出力]

(このメニュー項目は、アプリの起動後にのみ表示されます。)

Visual Studio

[表示] > [出力] > [Show output from: Debug] (デバッグから出力を表示する)

Android adb LogCat ログ

adb コマンドを実行したら、デスクトップから android_logcat.txt ファイルを添付して返します。 これらの手順では、接続されているデバイスは 1 つだけであることを前提としています。

Android デバッグ ログ」ページも参照してください。

Visual Studio

  1. [ツール] > [Android] > [Start Android Adb Command Prompt] (Android Adb コマンド プロンプトの起動)
  2. ログをクリーンアップします (adb logcat -c)。
  3. 問題を再現します。
  4. ログを出力します (adb logcat -vtime -d > "%USERPROFILE%\Desktop\android_logcat.txt")。

Visual Studio for Mac

  1. [ツール] > [Open Android SDK Command Prompt] (Android SDK コマンド プロンプトを開く)
  2. ログをクリーンアップします (adb logcat -c)。
  3. 問題を再現します。
  4. ログを出力します (adb logcat -vtime -d > ~/Desktop/android_logcat.txt)。

iOS シミュレーター ログ (Mac 上)

  • システム ログにアクセスするには、iOS Simulator アプリで [デバッグ] > [Open System Log...] (システム ログを開く) を選択します。

  • シミュレーターからのクラッシュ レポートを表示するには、Console.app を開き、~/Library/Logs > DiagnosticReports に移動します。

iOS デバイス ログ (Mac 上)

Visual Studio for Mac

[表示] > [Pads] (パッド) > [iOS Device Log] (iOS デバイス ログ)

Xcode

[ウィンドウ] > [デバイス] > ${DeviceName}

クラッシュ レポートは、[View Device Logs] (デバイス ログの表示) ボタンで取得できます。 デバイスのシステム ログは、ウィンドウ下部の表示矢印で表示されます。

Xcode 5

[ウィンドウ] > [オーガナイザー] > [デバイス] (タブ)> ${DeviceName}