SharePoint Online および OneDrive で「アクセスが拒否されました」または「このサイトにアクセスするには、アクセス許可が必要です」エラーが表示される

現象

ユーザーが SharePoint Online または OneDrive for Business サイトにアクセスしようとすると、次のいずれかのエラー メッセージが表示されます。

  • アクセスが拒否されました。
  • このサイトにアクセスするには、アクセス許可が必要です。
  • ディレクトリ内にユーザーが見つかりません。

ユーザーが SharePoint Online または OneDrive サイトから他のユーザーが共有しているファイルまたはフォルダーへのリンクにアクセスしようとすると、次のエラー メッセージが表示されます。

このリンクは使用できません。
申し訳ありませんが、現在サインインしているアカウントは保護されているユーザーの一覧に含まれていません。 別のメールを試すには、サインアウトしてもう一度リンクを開いてください。

原因

これらのエラーは、次のようなさまざまな理由で発生する可能性があります。

  • 影響を受けるユーザーのアクセス許可が正しく構成されていません。
  • 共有リンクへのアクセスに使用されるアカウントは、共有の招待が送信されたアカウントとは異なります。
  • サイト ユーザー ID が一致していません。 ID の不一致は通常、ユーザー アカウントが Microsoft 365 管理センターから削除された後で、削除されたアカウントで使用されていたユーザー プリンシパル名 (UPN) を使用して新しいアカウントが作成された場合に発生します。 UPN が同じであっても、新しいアカウントには新しい ID 値が割り当てられます。 ユーザーが既に SharePoint にログインしていて、後で別の OU に移動する場合、Active Directory 組織単位 (OU) と SharePoint の間のディレクトリ同期中にも同様の不一致が発生する可能性があります。

解決方法オプション 1: ユーザー アクセスの確認診断を実行する

注:

この診断は、GCC High または DoD 環境や、21Vianet が運営する Microsoft 365 では利用できません。

Microsoft 365 管理者は、テナント内で診断を実行して、ユーザー アクセスに影響を与える可能性のある問題を特定できます。

次の [テストの実行] ボタンを選択して、Microsoft 365 管理センターに診断を入力します。

診断は、SharePoint および OneDrive サイトにアクセスしようとする内部ユーザーやゲストに対して広範囲の検証を実行します。

解決方法オプション 2: 手動修正

アクセスの問題を手動で解決するには、関連するシナリオの手順に従います。

ユーザーが SharePoint サイトまたは別のユーザーの OneDrive サイトにアクセスできない

  1. ユーザーがサイトに対して持つ必要があるアクセス許可レベルを決定します。

  2. [アクセス許可の確認] 機能を使用してアクセス許可を確認します。

    1. SharePoint サイトの場合は、[設定] > >[サイトのアクセス許可] の順に選択します。 OneDrive サイトの場合は、[設定] > >[サイトの設定] > >[サイトのアクセス許可] の順に選択します。
    2. リボンで、[アクセス許可の確認] を選択します。
    3. [ユーザー/グループ] フィールドにユーザーの名前を入力し、[今すぐ確認] を選択します。
    4. ユーザーがサイトに対して持っているアクセス許可と関連するセキュリティ グループ (該当する場合) を確認します。
  3. ユーザーに適切なアクセス許可がない場合は、ファイルまたはサイトに対するアクセス許可をユーザーに付与します。

  4. ユーザーに引き続きエラー メッセージが表示される場合は、サイトからユーザーを削除します。 次に、ファイルまたはサイトに対するアクセス許可をユーザーに付与します。

    注: 引き続きゲスト アカウントでエラーが発生する場合は、Microsoft 365 管理センターからゲスト アカウントを完全に削除することをお勧めします。 ユーザーがサイト コレクションから削除されていることを確認してください。 次に、ファイルまたはサイトに対するアクセス許可をユーザーに付与します。

ユーザーが独自の OneDrive サイトにアクセスできない

この問題は通常、サイト ユーザー ID の不一致が原因で発生します。

この問題を解決するには、新しい UPN が存在するかどうかを確認します。 新しい UPN が存在する場合は、新しい UPN を削除し、元の UPN を復元します。

この手順の使用に慣れていない場合は、問題を解決する自動ソリューションについて、「SharePoint または OneDrive のサイト ユーザー ID の不一致を修正する」を参照してください。

エラーが発生しているユーザーをサイトから削除し、ファイルまたはフォルダーをもう一度共有します。