現象
SharePoint Online リストまたはライブラリでアラートを作成すると、次のエラー メッセージが表示されます。
問題が発生しました。 電子メール アドレスがありません。 アラートは正常に作成されましたが、有効な電子メールアドレスまたはモバイル アドレスがプロファイルに入力されるまで通知を受け取れません。
原因
このエラーは、SharePoint Online ユーザー プロファイルに関連付けられている電子メール アドレスがないために発生します。 このエラーは、ユーザーが自分のアカウントに割り当てられている Exchange Online ライセンスを持っていない場合に最も頻繁に発生します。
解決方法
この問題を解決するには、SharePoint Online を構成して、ユーザーが個人用サイト プロファイル内でメール アドレスを構成し、変更をサイトにレプリケートできるようにします。 SharePoint 管理者は、次の手順に従います。
https://portal.office.comで Office 365 ポータルを参照します
ウィンドウの上部にある Admin リンクを選択し、 SharePoint を選択します。
SharePoint 管理センターで、 ユーザー プロファイルを選択します。
[ People セクションで、 Manage ユーザー プロパティを選択します。
[作業用電子メール]プロパティ名を探し、そこにマウス ポインタを移動させます。
ドロップダウン矢印を選択し、 Edit を選択します。
[設定の編集] セクションで、[ユーザーがこのプロパティ設定の値を編集できるようにする] の横にあるオプションを選択します。
[ ポリシー設定 セクションで、 Replicable の横にあるチェック ボックスをオンにします。
Note
レプリケート可能な設定は、プロパティが組織内のすべてのサイト コレクションに確実に反映させるために必要です。
ページの一番下までスクロールし、 OKを選択します。
ユーザーはマイ サイト プロファイルを編集して、必要に応じて[勤務先の電子メール] フィールドを構成できるようになりました。 ユーザーの SharePoint アラートは、このフィールドのアドレスに送信されます。
さらにヘルプが必要ですか? SharePoint コミュニティにアクセスしてください。