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WindowsがMicrosoft Monitoring Agentを起動できない。

Note

Log Analytics エージェント (Microsoft Monitoring Agent (MMA) とも呼ばれます) は、2024 年 8 月に廃止される予定。 その結果、Microsoft Defender for Cloud のマシン プラン上の Defender for Servers と Defender for SQL サーバーが更新され、Log Analytics エージェントに依存する機能が再設計されます。 詳細については、「Log Analytics エージェントの提供終了に向けた準備」を参照してください。

この記事は、Windows がローカル コンピューターで Microsoft Monitoring Agent (Windows 用 Log Analytics エージェント) を起動しないシナリオのトラブルシューティングに役立ちます。 この問題が発生すると、"サービス固有のエラーで Microsoft Monitoring Agent サービスが終了しましたアクセスが拒否されました" というエラー メッセージが表示されます。

前提条件

現象

サービス スナップイン (services.msc) を開いて Microsoft Monitoring Agent サービスを起動しようとすると、ダイアログ ボックスが表示され、次のエラー メッセージが表示されます。

Windows がローカル コンピューターで Microsoft Monitoring Agent を起動できませんでした。 詳細については、システム イベント ログを確認してください。 Microsoft 以外のサービスの場合は、サービス ベンダーに問い合わせて、サービス固有のエラー コード 5 を参照してください。

イベント ビューアー スナップイン (eventvwr.msc) では、対応するシステム イベント ログに "アクセスが拒否されました" というエラー エントリが表示されます。

Log Name:      System
Source:        Service Control Manager
Date:          8/19/2021 3:03:27 PM
Event ID:      7024
Task Category: None
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      ContosoServer2k8R2
Description:
The Microsoft Monitoring Agent service terminated with service-specific error Access is denied.

原因

レジストリは、Microsoft Monitoring Agent から SecureStorageManager パラメーターへの読み取り/書き込みアクセスを拒否しています。 このシナリオを確認するには、"アクセスが拒否されました" というエラー メッセージが表示されたら、次の手順に従います。

  1. プロセス モニターを開きます。

  2. 次の値を持つエントリを探します。

    Column Value
    プロセス名 HealthService.exe
    操作 RegOpenKey
    Path HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager
    結果 アクセスが拒否されました
    詳細 必要なアクセス: 読み取り/書き込み
  3. Startを選択し、「regedit」と入力し、Registry Editor を選択します。

  4. レジストリ エディターで、 View メニューを選択します。 アドレス バーの横にチェック マークがない場合、そのメニュー項目を選択します。

  5. アドレス バー (メニューの下とナビゲーション ウィンドウの上) で、既存のテキストを削除し、「 HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager」と入力し、Enter キーを押します。

  6. メニューの Edit>Permissions を選択します。

  7. [SecureStorageManager の Permissions ] ダイアログ ボックスで、 Group またはユーザー名 ボックスに SYSTEM および Administrators (<ComputerName>)のエントリがあることを確認します。 これらの各エントリについて、<GroupOrUserName の Permissions ボックスの Full Control 行を調べて>Allow 列が選択されているかどうかを確認します。

システム ユーザーまたは管理者グループに対してフル コントロールは明示的に許可されていませんか? その場合、だれかが既定のアクセス許可を変更しました。 この変更により、Microsoft Monitoring Agent には、 SecureStorageManager パラメーターにアクセスするアクセス許可がなくなりました。

次の条件に該当する場合は、既定のアクセス許可を変更できます。

  • サーバーが強化されます。

  • ユーザー、アプリケーション、またはスクリプトは、レジストリ内の読み取り/書き込みレベルより小さい既定のアクセス許可を変更します。

解決策

システム ユーザーと管理者の SecureStorageManager パラメーターにフル コントロールを復元します。 これを行うには、次の手順を実行します。

警告

レジストリ エディタや他の方法を使用してレジストリを変更する際、適切に変更しないと重大な問題を引き起こす可能性があります。 場合によっては、オペレーティング システムの再インストールが必要になります。 マイクロソフトは、このような問題の解決に関して、一切責任を負わないものとします。 レジストリの変更はユーザー自身の責任において行ってください。

  1. (推奨) レジストリをバックアップします

  2. レジストリ エディターに戻るか、もう一度開きます。

  3. アドレス バーで、 SecureStorageManager パラメーター (HKLM\SYSTEM\CurrentControlSet\Services\HealthService\Parameters\SecureStorageManager) のレジストリ パスを再入力し、Enter キーを押します。

  4. Edit>Permissions を選択し、SYSTEM ユーザーと Administrators (<ComputerName>) グループの Full Control (Allow ) の既定のアクセス許可を再適用します。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。