次の方法で共有


Azure Windows VM に接続しようとしたときにアカウントにサインインできない

適用対象: ✔️ Windows VM

この記事では、リモート デスクトップ プロトコル (RDP) を使用して Azure Windows VM に接続しようとすると、"アカウントにサインインできません" というエラーをトラブルシューティングする方法について説明します。

現象

RDP を使用して Windows VM に接続しようとすると、次のエラー メッセージが表示されます。

アカウントにサインインできません
この問題は、多くの場合、アカウントからサインアウトしてからサインインし直すことで解決できます。 今すぐサインアウトしないと、作成したファイルや変更は失われます。

アプリケーション イベント ログには、RDP 接続の試行ごとにイベント ID 1511 がログに記録されます。

ID: 1511
レベル: エラー
ソース: Microsoft-Windows-User Profiles Service
マシン: RDPDemo.contoso.net
メッセージ: Windows はローカル プロファイルを見つけられないので、一時的なプロファイルでログオンしています。 このプロファイルに加えた変更は、ログオフすると失われます。

原因

この問題は、ユーザーのローカル プロファイルが破損していて、Windows が RDP セッション用の新しいローカル プロファイルを作成できない場合に発生する可能性があります。

ソリューション

このドキュメントのいずれかの解決策に進む前に、スナップショットを取得して VM OS ディスクをバックアップしてください。 トラブルシューティングの間に行われた変更を元に戻す必要がある場合は、スナップショットを使用してディスクを作成し直すことができます。

Azure シリアル コンソールを使用したオンライン修復

  1. Azure シリアル コンソールを使用して VM に接続した後、PowerShell セッションを開始します。 Azure シリアル コンソールが動作しない場合は、リモート PowerShell を使用して VM に接続します。 詳細については、リモート ツールを使用して Azure VM に関する問題のトラブルシューティングを行う方法に関する記事を参照してください。

  2. VM に接続した後、次のコマンドを実行して、ユーザー プロファイルのエントリの一覧を表示します。 名前の末尾に ".bak" 拡張子が付いているプロファイルを見つけます。

    reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList" /s | more
    
  3. キー "ProfileImagePath" の値を調べて、影響を受けるユーザーのプロファイル エントリを特定します。

  4. 影響を受けるユーザー (".bak" で終わる) のユーザー プロファイル バックアップ エントリを削除し、組み込みのシステム アカウントのエントリを削除しないでください S-1-5-18S-1-5-19、および S-1-5-20:

    reg delete "HKLM\SOFTWARE\Microsoft\WindowsNT\CurrentVersion\ProfileList\<GUID>.bak"
    
  5. VM への接続を試みて、問題が解決されるかどうかを確認します。

  6. 問題が引き続き発生する場合は、影響を受けるユーザーのユーザー プロファイル エントリを削除してみてください。

オフラインでの修復

Azure シリアル コンソールまたは他のリモート ツールを使用して VM にアクセスできない場合は、オフライン モードで修復を実行する必要があります。

  1. VM 修復プロセスのステップ 1 から 3 のようにして、修復 VM を作成します。 障害が発生した VM のコピーされた OS ディスクが、修復 VM に自動的にアタッチされます。 通常、ディスクはドライブ F としてアタッチされます。
  2. 修復 VM に接続します。
  3. 修復 VM で、レジストリ エディター (regedit.exe) を開始します。 HKEY_LOCAL_MACHINE キーを選択し、メニューから [ファイル] > [ハイブの読み込み] を選択します。 SOFTWARE hive ファイルを F:\Windows\System32\config フォルダーに見つけて読み込み、hive の名前として「RepairSOFTWARE」と入力します。
  4. RepairSOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList に移動します。
  5. キー "ProfileImagePath" の値を調べて、影響を受けるユーザーのプロファイル エントリを特定します。
  6. 影響を受けるユーザー (".bak" で終わる) のユーザー プロファイル バックアップ エントリを削除し、組み込みのシステム アカウント S-1-5-18S-1-5-19、および S-1-5-20 のエントリを削除しないでください
  7. VM 修復プロセスのステップ 5 を使用して、修復された OS ディスクを障害が発生した VM にマウントします。
  8. 障害が発生した VM を起動し、RDP を使用して VM への接続を試みます。 問題が引き続き発生する場合は、影響を受けるユーザーのユーザー プロファイル エントリを削除してみてください。

次のステップ

この記事で Azure の問題に対処できない場合は、MSDN および Stack Overflow の Azure 関連フォーラムを参照してください。 問題をこれらのフォーラムに投稿するか、または Twitter の @AzureSupport に投稿できます。 Azure サポート要求を送信することもできます。

サポートリクエストを送信するには、Azure サポートページに移動しGet サポートを選択します。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。