次の方法で共有


会話前アンケートの電子メール フィールドの検証が期待どおりに機能しない

この記事では、Microsoft Dynamics 365 カスタマー サービスのライブ チャット ウィジェットの 会話前調査 の電子メール フィールドの検証について説明します。

症状

会話前アンケートの電子メール フィールドでは、正しくないメール形式が検証されないため、ユーザーは間違った形式のメール アドレスを入力できます。 この問題により、正確なユーザー情報の収集が困難になり、通信に影響する可能性があります。

原因

既定のライブ チャット ウィジェットには、会話前アンケートで電子メール形式を検証するための組み込み機能は含まれていません。 電子メール形式の検証を適用するには、カスタマイズが必要です。

解決策

この問題を解決するには、電子メールの検証をサポートするカスタム ライブ チャット ウィジェットを作成します。 「カスタム ライブ チャット ウィジェットを開発する」のガイダンスに従ってください。

または、"識別" トピックを使用して Copilot ボットを構成して、電子メールの収集と検証を処理することもできます。 詳細については、「Copilot Studio でトピックを作成および編集するを参照してください。