次の方法で共有


SLA KPI インスタンスがコンプライアンス違反または非準拠に近づけず、SLA KPI インスタンス タイマーが引き続き実行されます

この記事では、サービス レベル アグリーメント (SLA) KPI インスタンスが Nearing non-compliance または 非準拠 状態に達せず、SLA KPI インスタンス タイマーが Microsoft Dynamics 365 Customer Service で引き続き実行される問題の解決策について説明します。

現象

SLA KPI インスタンス タイマー用に作成されたフローの実行は、次のライセンス エラー メッセージで失敗します。

OrganizationContext = YYYY で SystermUserId = XXXX を持つユーザーにはライセンスがありません。

原因

SLA KPI インスタンスを Nearing non-compliance または Non-complaint 状態に移行するには、SLAInstanceMonitoringWarningAndExpiryFlowが必要です。 このフローは、組織内の最初の SLA をアクティブにするユーザーのコンテキストで常に機能します。 組織で最初の SLA をアクティブ化するユーザーは、フローの実行に必要なすべてのライセンスを持っている必要があります。 フローは、 prvReadSLAKPIInstanceprvWriteSLAKPIInstanceのグローバル レベルで SLA KPI 特権を持つユーザーのみが、オフとオンを切り替える必要があります。

ユーザーに必要なライセンスのいずれかが不足している場合、対応する SLA KPI インスタンス用に作成されたフロー実行は、ライセンスが必要なエラー "The user with SystermUserId = XXXX in OrganizationContext = YYYY is not licensed" (OrganizationContext = YYYY で SystermUserId = XXXX がライセンスされていません) で失敗します。したがって、SLA KPI インスタンスが Nearing non-compliance または Non-complaint 状態に到達することは決してなく、SLA KPI インスタンス タイマーは引き続き実行されます。

さらに、フローの現在の所有者は、SLA KPI インスタンスの読み取りおよび書き込みアクセス権を持つ必要なアクセス許可を持っている必要があります。

考えられる軽減策の手順 1: フローの所有者を変更する

ヒント

フローの現在の所有者であるユーザーを組織から削除する必要がある場合は、最初にフローの所有者を別のユーザーに変更する必要があります。 この新しいユーザーには、必要なすべての権限も必要です。 新しい所有者が追加されたら、所有者リストから前の所有者を削除できます。 このアクションにより、フローの実行は問題なく引き続き実行されます。

失敗したフローの現在の所有者を変更するには、次の手順に従います。

  1. Power Automate で、Default ソリューション>Cloud フローに移動します。
  2. エラーのある失敗したフローを検索します。
  3. 編集を選択します。 新しいポップアップ メニューが表示され、新しい所有者を設定できます。
  4. 所有者フィールドで、現在の所有者を削除し、新しい所有者を追加します。 新しい所有者に必要なすべてのフロー ライセンスがあることを確認します。

考えられる軽減策の手順 2: 静的フローをオフにして再びオンにする

  1. Power Automate で、Default ソリューション>Cloud フローに移動します。
  2. [クラウド フロー] で、[ SLAInstanceMonitoringWarningAndExpiryFlow] を選択します。
  3. 状態が On の場合でも、 [無効にする ] を選択し、[オン ] を選択

これにより、新しい KPI インスタンスの問題が修正されます。

古い KPI インスタンスの場合は、独自のロジックを使用して状態を変更したり、スクリプトのMicrosoft サポートに連絡したりできます。 影響を受けるレコードの詳細と SLA KPI インスタンスの必要な状態をチームに提供することを忘れないでください。

考えられる軽減策の手順 3: フローの名前を変更してトリガーする

Note

これらの手順は、 Microsoft Entra ユーザーが実行する必要があります。

  1. Power Automate で、Default ソリューション>Cloud フローに移動します。
  2. [クラウド フロー] で、[ SLAInstanceMonitoringWarningAndExpiryFlow] を選択します。
  3. フローがトリガーされていないことを確認します。
  4. フローを別の名前で更新して保存し、有効にします。 フローの実行が開始されます。
  5. 上記で作成したフローのインスタンスがインスタンス化されていることを確認します。

SLA の状態は正常に更新されます。

フローをオンまたはオフにする方法を示すスクリーンショット。

関連項目