この記事では、 サービス レベル アグリーメント (SLA) タイマー がタイマーの失敗時刻より前に実行または期限切れになる問題の解決策について説明します。
現象
SLA タイマーは、タイマーのエラー時間の前に実行を続けるか、期限切れになります。
原因
ワークフロー内の既存の SLA KPI インスタンスのエラーと警告時間の更新はサポートされていません。
静的フロー (SLAInstanceMonitoringWarningAndExpiryFlow
) は、SLA KPI インスタンスが作成された場合にのみトリガーされます。 既存の SLA KPI インスタンスのエラー時間と警告時間が更新されると、静的フローを想定どおりに実行できないため、予期しない動作が発生する可能性があります。
解決方法
この問題を解決するには、カスタム ワークフローとプラグインを使用して既存の KPI をキャンセルし、既存の SLA KPI インスタンスのエラーと警告時間を更新するのではなく、新しい SLA KPI インスタンスをトリガーできます。
Note
既存の SLA KPI インスタンスのカスタム ロジックによってエラー時間と警告時間が更新された場合、これらの新しい時刻は考慮されません。