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テーブル ビューに関する問題のトラブルシューティング

この記事は、テーブル ビューに関連する問題のトラブルシューティングと解決に役立ちます。

問題 1 - テーブル ビューの特定の列にデータが表示されない

原因

この問題は、ビュー ODATA ファイル (layoutxml/api/data/fetchxml/savedqueries(ViewId)) 内のの列名の不一致が原因で発生しています。

解決方法

この問題を解決するには、この問題の原因となっている列を削除して追加する必要があります。 これにより、 layoutxmlfetchxml の列名が確実に一致します。

注意

問題の解決を開始する前に、この問題が発生しているビューをメモしておきます。

  1. 設定>カスタマイズ>システムのカスタマイズに移動します。

  2. Entity>Viewsを選択し、この問題が発生しているビューを選択します。 この例では、テーブル Account を選択し、 Accounts Being Followed として表示します。

    テーブルからビューを選択します。

  3. [その他 アクション>編集を選択します。

    ビューの編集ページが開きます。

    ビュー編集ページを開いてビューを編集します。

  4. 問題の原因となっている列を選択し、 Remove を選択します。 この例では、削除する列 Email (プライマリ連絡先) を選択します。

    ビューから列を削除します。

    列がビューから削除されます。

  5. 削除した列を再度追加します。 [列の追加]を選択し、削除した列を再追加します。 この例では、削除された列 Email (Primary Contact) を追加しています。

    削除された列を追加し直します。

    列のデータが正しく表示されます。

問題 2 - テーブル ビューに一部のレコードが表示されない

原因

この問題は、ビューでのデータのフィルター処理が原因で発生しています。

決議

この問題を解決するには、ビューのフィルターを編集または削除する必要があります。 これにより、ビューにフィルターが適切に適用されます。

注記

問題の解決を開始する前に、この問題が発生しているビューをメモしておきます。

  1. 設定>カスタマイズ>システムのカスタマイズに移動します。

  2. Entity>Viewsを選択し、この問題が発生しているビューを選択します。 この例では、テーブル Account を選択し、 Accounts I Follow として表示します。

    テーブルからビューを選択します。

  3. [その他 アクション>編集を選択します。

    ビューの編集ページが開きます。

    ビューの編集ページを開き、フィルターを編集または削除します。

  4. [フィルター条件の編集 を選択し 更新または削除してフィルター条件を再確認します。

    フィルター条件を更新またはクリアします。

    ビュー内のレコードが正しく表示されます。

問題 3 - 営業案件、見積もり、注文、請求書のサブグリッドに一部のレコードが表示されない

営業案件、見積もり、注文、または請求書のレコードに取り組んでいる間に、一部のレコードが欠落している可能性があります。

原因

サブグリッドに対するカスタマイズが原因でエラーが発生したため、一部のレコードが表示されない場合があります。

解決方法

不適切なカスタマイズの問題を解決するには、次の手順に従って、サブグリッドが正しく構成されていることを確認します。

  1. アプリでのナビゲーション バーで、 設定 アイコンを選択して 詳細設定 を選択します。

    [設定] メニューの [詳細設定] リンク。

    ビジネス管理設定 ページが新しいタブで開きます。

  2. ナビゲーション バーで 設定 を選択して カスタマイズカスタマイズ を選択します。

  3. システムのカスタマイズを選択。

  4. ソリューション エクスプローラーの ComponentsEntities を展開し、 Opportunity を展開して、 Forms を選択します。

  5. Main 型の営業案件フォームを開きます。

  6. ダブルクリックして、Product Line Items セクションの Connections セクションを選択します。

    製品明細サブグリッド。

    [プロパティの設定] ダイアログ ボックスが開きます。

    営業案件製品グリッドのプロパティを設定します。

  7. [ Controls ] タブでダブルクリックし、[編集可能なグリッド 選択

    [編集可能グリッド] オプションをダブルクリックします。

  8. すべての値が正しく設定されていることを確認します。

    • グリッドビュー: 商機製品 インライン編集ビュー

    • 入れ子になったグリッド ビュー: 鉛筆アイコンを選択し、次の詳細を入力します。

      [プロパティの構成] ダイアログ ボックスの詳細。

      • 表: 営業案件製品
      • 営業機会商品のインライン編集ビュー:バンドル商品
    • 入れ子になったグリッドの親 ID: parentbundleidref

    • 列別のグループ化: 有効 (列挙型)

    • フィルター可能: 有効 (選択肢)

    • 入れ子になったグリッド列ヘッダーを非表示にする: 列を非表示にする

      注意

      製品バンドルを使用し、製品グリッドでこれらのバンドルされた品目を編集する場合は、入れ子になったグリッド列ヘッダーを非表示としてShow 列を選択します。

問題 4 - [製品の追加] ダイアログの [既存の製品] フィールドの既定のビューとしてカスタム ビューを設定できない

営業案件、見積もり、注文、または請求書に製品を追加するには、製品の追加 ダイアログの Existing product ルックアップ フィールドから製品を選択します。 ルックアップ フィールドの既定のビューをユーザー設定ビューに変更した場合、フィールドにはユーザー設定ビューの製品は表示されません。

原因

選択した価格表の製品を表示できるようにするため、参照は常に、親価格表の Products という名前のシステム ビューに既定で設定されます。 そのため、既定値を変更した場合でも、ルックアップ フィールドは既定値を [親価格表 ビューの Products に戻します。

解決方法

この動作は、設計どおりに動作します。 既定のビューを設定することはできませんが、 Existing products ルックアップ フィールドのビューに手動で切り替えることができます。

[製品の追加] ダイアログ ボックスの [ビューの変更] オプション。

問題 5 - [製品] タブで入れ子になったバンドルアイテムを更新できない

原因

商機において、Product タブでネストされたバンドル項目を更新すると、保存アイコンが無効になります。 この問題は、カスタマイズ時に入れ子になったグリッド列のヘッダーが Opportunity Product Inline Edit View の下に隠されているために発生します。

解決方法

この問題を解決するには、次の手順に従って、営業案件フォームの製品の入れ子になったグリッド列のヘッダーを表示します。

  1. アプリでのナビゲーション バーで、 設定 アイコンを選択して 詳細設定 を選択します。

    [設定] メニューの [詳細設定] をクリックします。

    ビジネス管理設定 ページが新しいタブで開きます。

  2. ナビゲーション バーで 設定 を選択して カスタマイズカスタマイズ を選択します。

  3. システムのカスタマイズを選択。

  4. ソリューション エクスプローラーの ComponentsEntities を展開し、 Opportunity を展開して、 Forms を選択します。

  5. フォーム型の Opportunity フォーム Main を開きます。

  6. [ Product Line Items セクションで、ダブルクリックして Opportunity products セクションを選択します。

    商談製品を選択してください。

    [プロパティの設定] ダイアログ ボックスが開きます。

    営業案件製品グリッドのプロパティを設定します。

  7. [ Controls ] タブでダブルクリックし、[編集可能なグリッド 選択

    [コントロール] タブで [編集可能グリッド] を選択します。

  8. [ 編集可能なグリッド ] セクションで、[入れ子になったグリッド列ヘッダーを非表示にする] の横にある鉛筆アイコン 選択

    [入れ子になったグリッド列ヘッダーを非表示にする] を選択します。

  9. [構成プロパティ] ダイアログ ボックスで、[静的オプションへのバインド] の下にある [列ヘッダーを表示] を選択します。

    [プロパティの構成] ダイアログ ボックスで [列ヘッダーの表示] を選択します。

  10. 構成を保存し、公開します。

問題 6 - サイト マップから営業案件を選択するとレガシ Web クライアントでは営業案件レコードが表示されないが、統合インターフェースでは表示される

原因

テーブル ビューに基づいて、レコードが一覧に表示されます。 この問題は、テーブルの既定のビューとしてマークされたパブリック ビューがない場合に発生する可能性があります。

解決方法

テーブルのパブリック ビューの 1 つを既定として選択します。 これにより、ビューが期待どおりに表示されます。 ビューを既定のビューにする方法については、「 モデル駆動型アプリの既定のビューを指定する」を参照してください。

注意

それでもレコードが表示されない場合は、ブラウザーのキャッシュをクリアして、もう一度やり直してください。