Microsoft Office Outlook 用 Microsoft Dynamics CRMを構成するときにオブジェクト エラーをキャストできません

この記事では、Microsoft Office Outlook 用 Microsoft Dynamics CRMを構成するときに発生するエラーの解決策について説明します。

適用対象: Microsoft Dynamics CRM Online、Microsoft Dynamics CRM 2016、Microsoft Office Outlook 用 Microsoft CRM client、Microsoft Dynamics CRM 2015、Microsoft Dynamics CRM 2013
元の KB 番号: 3182511

現象

Microsoft Office Outlook 用 Microsoft Dynamics CRMを構成しようとすると、次のエラーが表示されます。

"Microsoft Dynamics CRM サーバーとの通信に問題があります。 サーバーが使用できない可能性があります。 後でもう一度お試しください。 問題が解決しない場合は、システム管理者に問い合わせてください。

'System.Int32' 型のオブジェクトを 'System.String' 型にキャストできません。 を Microsoft.Crm.Application.Outlook.Config します。OutlookCRMDatastoreInstaller.GetAllCRMOrgsInOutlookProfile()..."

原因

このエラーは、以前の構成試行で Outlook で CRM データ ファイルが部分的に作成された場合に発生する可能性があります。

解決方法

Outlook で不完全な CRM データ ファイルを削除するには、次の手順に従います。

  1. Windows でコントロール パネルを開きます。 コントロール パネルが見つからない場合は、[スタート] を選択し、コントロール パネルを検索します。
  2. [ 検索 ] ボックスを使用してメールを検索 します
  3. [メール] を選択します。
  4. [ データ ファイル ] ボタンを選択します。
  5. Microsoft Dynamics CRMデータベースの名前を持つ行が表示される場合は、その行を選択し、[削除] を選択します
  6. 確認を求めるメッセージが表示されたら、[ はい ] を選択します。
  7. [ データ ファイル ] ダイアログを閉じます。
  8. CRM for Outlook の構成をもう一度試みます。

CRM Online organizationを使用した CRM for Outlook のインストール、有効化、または接続に関する問題が解決しない場合は、Microsoft サポートと Recovery Assistant を実行します。

詳細

ログ ファイルで見つかったエラーには、次の詳細が含まれています。

エラー|例外: 型 'System.Int32' のオブジェクトをキャストして 'System.String' と入力できません。 を Microsoft.Crm.Application.Outlook.Config します。OutlookCRMDatastoreInstaller.GetAllCRMOrgsInOutlookProfile()
を Microsoft.Crm.Application.Outlook.Config します。ConfigInfo..ctor()
を Microsoft.Crm.Application.Outlook.Config します。MainForm..ctor()
を Microsoft.Crm.Application.Outlook.Config します。ClientConfig.CreateAndShowForm(Boolean runInsideOutlook)
を Microsoft.Crm.Application.Outlook.Config します。ClientConfig.AddDeployment_FullUI(Boolean runInsideOutlook)
を Microsoft.Crm.Application.Outlook.Config します。ClientConfig.Run(Boolean runInsideOutlook)
を Microsoft.Crm.Application.Outlook.Config します。ClientConfig.Start(String[] args, Boolean runInsideOutlook)