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Microsoft Dynamics GP の General Ledger で期末処理を実行しようとするとエラー: 利益保持アカウントが見つかりません

この記事では、Microsoft Dynamics GP の General Ledger で期末処理を実行するときに発生するエラーの解決策について説明します。

適用対象: Microsoft Dynamics GP
元の KB 番号: 850741

現象

Microsoft Dynamics GP の General Ledger で年末終了プロセスを実行しようとすると、次のエラー メッセージが表示されます。

利益保持アカウントが見つかりません。

利益留保勘定が見つかりませんでした。

原因

この問題は、一般台帳の設定 ウィンドウで部門勘定セグメントに対する閉じる] チェック ボックスをオンにした場合に発生します。

さらに、エラー メッセージは、次のいずれかの原因で発生する可能性があります。

原因 1

設定されている利益保持アカウントは 1 つだけです。 ただし、[一般会計の設定] ウィンドウで [ 部門勘定セグメントに対して閉じる ] チェック ボックスがオンになっています。 Resolution 1 を参照してください。

原因 2

利益留保勘定は、近い共通セグメントなしで設定されます。 Resolution 2 を参照してください。

原因 3

[ 部門勘定セグメントに閉じる ] チェック ボックスがオンになっています。 ただし、利益留保勘定はセグメント部門ごとに設定されていません。 Resolution 3を参照してください。

原因 4

利益留保勘定には空白スペースがあります。 Resolution 4を参照してください。

原因 5

GL00105 アカウント インデックス テーブルに破損したレコードがあります。 Resolution 5 を参照してください。

原因 6

部門別 RE アカウントのクローズを使用する場合は、ユニット アカウントを探しています。 Resolution 6 を参照してください。

解決方法

これらの解決策を実行する前に、他のすべてのユーザーが Microsoft Dynamics GP または Microsoft Business Solutions - Great Plains からログアウトしていることを確認してください。 また、会社のデータベースの復元可能なバックアップを作成してください。

解決策 1

この問題を解決するには、[元帳の設定] ウィンドウの [部門別勘定セグメントに閉じる ] チェック ボックスをオフにします。 これを行うには、次の手順を実行します。

  1. [General Ledger Setup] ウィンドウを開き、[ Microsoft Dynamics GP メニューの [ツール] をクリックし、 Setup をポイントし、 Financial をポイントして、[ General Ledger をクリックします。
  2. [元帳の設定] ウィンドウで、 部門勘定セグメントに閉じる チェック ボックスをオフにします。
  3. [OK] をクリックして変更を保存します。

解決策 2

この問題を解決するには、異なる利益保持勘定番号のセグメントを1つだけに制限してください。 口座番号の複数のセグメントを閉じることはできません。

この例では、次の利益保持勘定番号が存在します。

  • A-000-3030-00
  • B-100-3030-00
  • C-200-3030-00

この例では、口座番号の 2 番目のセグメントを使用して閉じることはできません。 2 番目のセグメントは 000、100、200 です。 閉じるセグメントを決定した後、残りのセグメントは同じである必要があります。 したがって、この例では、次のオプションがあります。

  • 2 番目のセグメントを使用して終了する場合は、最初のセグメント (文字) を変更して、すべてのアカウントで同じになるようにする必要があります。 たとえば、2番目のセグメントを使用して終了し、部門繰越利益を使用して終了するためには、最初のセグメントを以下のように変更してください。
    • A-000-3030-00
    • A-100-3030-00
    • A-200-3030-00
  • 最初のセグメントを使用して終了する場合は、すべてのアカウントで同じになるように 2 番目のセグメントを変更する必要があります。 2 番目のセグメントは、次のいずれかのオプションを使用して変更できます。
    • A-000-3030-00、B-000-3030-00、C-000-3030-00
    • A-100-3030-00、B-100-3030-00、C-100-3030-00
    • A-200-3030-00、B-200-3030-00、C-200-3030-00

解決策 3

セグメント区分に対して作成された繰越利益剰余金がないことを確認してください。 これを行うには、次の手順を実行します。

  1. Account Segment Setup ウィンドウを開き、Microsoft Dynamics GP メニューの Tools をクリックし、Setup をポイントし、Financial をポイントして、[Segment] をクリックします。

  2. Segment フィールドの横にあるルックアップ ボタンをクリックし、General Ledger Setup ウィンドウで割り当てられているアカウント セグメントをメモします。

  3. Number フィールドの横にあるルックアップ ボタンを使用します。

  4. セグメント参照ボタンを使用して表示できるセグメント番号に注意してください。

  5. [アカウントのメンテナンス] ウィンドウを開きます。 これを行うには、[カード] をクリックしをポイントしてAccountクリックします

  6. 手順 4 でメモしたすべてのセグメントに、対応する利益保持アカウントが設定されていることを確認します。

    例:

    次の条件に該当します。

    • 利益保持アカウント番号は 000-3030-00 です。
    • 勘定番号の最初のセグメントは、分割勘定セグメントとして設定されます。
    • 最初のセグメントには、000、100、200、300、400 という番号が設定されていることにご説明しました。

    この例では、次の利益保持アカウント番号も設定されていることを確認する必要があります。

    • 100-3030-00
    • 200-3030-00
    • 300-3030-00
    • 400-3030-00
  7. すべてのセグメントが設定されていない場合は、 Account Maintenance ウィンドウで設定します。 これを行うには、[カード] をクリックしをポイントしてAccountクリックします

解決策 4

この問題を解決するには、利益保持アカウント番号に空白文字が含まれているかどうかを判断します。 これを行うには、次の手順を実行します。

  1. [アカウントのメンテナンス] ウィンドウを開きます。 これを行うには、[カード] をクリックしをポイントしaccountクリックします

  2. 利益保持アカウントの 1 つを選択し、アカウント番号を調べて、スペースがないことを確認します。

    例:

    • 利益保持アカウント番号は 000-3030-00 です。
    • 勘定番号の最初のセグメントは、分割勘定セグメントとして設定されます。
    • 最初のセグメントには、000、100、200、300、400 という番号が設定されていることにご説明しました。

    この例では、次の利益保持アカウント番号も設定されていることを確認する必要があります。

    • 100-3030-10
    • 200-3030-20
    • 300-3030-30
    • 400-3030-40

    ただし、最初のセグメントのセグメント長を意図せずに 4 文字に増やした可能性があり、Microsoft Dynamics GP は、最初に作成した利益保持アカウントを認識しません。 最初のセグメントを増やすと、アカウント番号は次のようになります。

    • 100X-3030-10
    • 200X-3030-20
    • 300X-3030-30
    • 400X-3030-40

    注意

    これらの数値では、X は空白を表します。

    アカウント番号にスペースがある場合は、次の手順に進みます。

  3. [調整] ウィンドウを開きます。 これを行うには、 Microsoft Dynamics GP メニューの [ツール] をクリックし、 ユーティリティをポイントし、 System をポイントして、[ Reconcile] をクリックします。

    注記

    [リコンサイル]コマンドは、アカウント セグメントの形式を元のセグメント長に戻します。 アカウントの実際の最初のセグメントの長さがスペースを除いて4文字ではない場合にのみ、調整は機能します。 つまり、例のように 1000-1100-00 のような最初のセグメントを持つアカウントはありません。 この場合、セグメントの長さは 3 文字に戻ります。

  4. Account 形式のセットアップを選択し、Insert をクリックします。

  5. [ Reconcile をクリックし、エラー ログを画面に出力します。

    メモ

    アカウント インデックス マスター (GL00105) テーブルには、アカウントの長さが 4 文字のアカウントが含まれている可能性があります。 そのため、SQL メンテナンスを使用してテーブルを再構築する必要があります。

  6. [SQL メンテナンス] ウィンドウを開きます。 これを行うには、 Microsoft Dynamics GP メニューの Maintenance をポイントし、 SQL をクリックします。

  7. 会社のデータベースを選択し、 Microsoft Dynamics GPProduct を選択します。

  8. Financial 系列のアカウント インデックス マスター テーブルを選択します。

  9. すべてのチェック ボックスをオンにし、[ Process] をクリックします。

    GL00105 テーブルが再作成されたら、リンクの確認を使用してデータを復元する必要があります。

  10. [リンクの確認] ウィンドウを開きます。 これを行うには、Microsoft Dynamics GP メニューで Maintenance をポイントし、リンクのチェックをクリックします。

  11. Series として Financial を選択し、アカウント マスター論理テーブルを挿入します。

  12. OK をクリックしてプロセスを開始します。

    ノート

    アカウント マスター (GL00100) テーブルにある情報が、GL00105 テーブルに設定されます。

解決策 5

  1. SQL Server Management Studioを開きます。

  2. クエリ ウィンドウで、会社のデータベースに対して次のスクリプトを実行します。

    Delete GL00105
    
  3. Microsoft Dynamics GP を開きます。 Microsoft Dynamics GP メニューで Maintenance にポイントして、リンクのチェック をクリックします。

  4. ファイナンシャルシリーズを選択します。

  5. Logical Tables リストで、Account Master をクリックして選択します。 挿入をクリックします。

  6. 次に、 OK をクリックしてチェック リンクを実行します。 エラー ログを画面に出力します。

  7. もう一度テストします。

解決策 6

正常に閉じることができるように、"ユニット アカウント" を考慮するために、空白のセグメントを持つ追加の部門 RE アカウントを設定する必要がある場合があります。 (部門別 RE アカウントの外観と終了するセグメントと比較して、ユニット アカウントの構造を表示します)。RE プロセス中にシステムがユニット アカウントを見てはいけないため、品質の問題がログに記録されています。