この記事では、Microsoft Dynamics GP を起動するときに発生するエラーの解決策について説明します。
適用対象: Microsoft Dynamics GP
元の KB 番号: 916679
現象
Microsoft Dynamics GP を起動すると、次のエラー メッセージが表示されます。
ユーザー・アクティビティー・ファイルからログインが削除されたため、アカウンティング・システムに入れることはできません。
原因
この問題は、クライアントの自動更新が発行されるときに発生します。 さらに、Microsoft Windows インストーラー ファイル (.msp ファイル) のパスが正しくないか、.msp ファイルがありません。
解決方法
この問題を解決するには、以下のいずれかの方法を使用します。
方法 1
クライアント更新プログラムがすべてのクライアントに既にインストールされている場合は、発行されたクライアント更新プログラムを削除します。 これを行うには、次の手順に従います。
- システム管理者 (sa) ユーザー アカウントを使用して Microsoft Dynamics GP にサインインします。
- 適切な手順を使用します。
- Microsoft Dynamics GP で、[Microsoft Dynamics GP] メニューの [ツール] をポイントし、[セットアップ] をポイントし、[システム] をポイントして、[クライアント更新プログラム] を選択します。
- Microsoft Dynamics GP 9.0 で、[ツール] メニューの [セットアップ] をポイントし、[システム] をポイントして、[クライアントの更新プログラム] を選択します。
- [ クライアントの自動更新の管理 ] ウィンドウで、[ 更新名 ] ボックスの横にあるアイコンを選択します。
- [ 更新プログラム ] ウィンドウで、インストールした更新プログラムを選択し、[選択] を 選択します。
- [ クライアントの自動更新の管理 ] ウィンドウで、[ 削除] を選択します。
方法 2
クライアントの更新を維持する場合は、.msp ファイルが存在し、.msp ファイルのパスが正しいことを確認します。 これを行うには、次の手順に従います。
- sa ユーザー アカウントを使用して Microsoft Dynamics GP にサインインします。
- [ ツール ] メニューの [ セットアップ] をポイントし、[ システム] をポイントし、[ クライアントの更新プログラム] を選択します。
- [ クライアントの自動更新の管理 ] ウィンドウで、[ 更新名 ] ボックスの横にあるアイコンを選択します。
- [ 更新] ウィンドウで、.msp ファイルのパスが正しいことを確認します。 パスが正しくない場合は修正してください。
- .msp ファイルがパスの末尾にあるディレクトリにあることを確認します。
方法 3
ユーザーがシステムにサインインできない場合は、DYNAMICS データベースの自動クライアント更新テーブルからクライアントの自動更新を削除します。 これを行うには、次の手順に従います。
DYNAMICS データベースのバックアップがあることを確認します。
SQL Query Analyzer または SQL Server Management Studio を開きます。
クライアントの自動更新をすべて表示するには、次の SQL ステートメントを実行します。
select * from DYNAMICS..SYUPDATE
有効な UNCPath がないクライアント自動更新を削除します。 これを行うには、次のスクリプトを実行します。
delete DYNAMICS..SYUPDATE where UPDATENAME = 'XXXX'
注
'XXXX' を正しい更新プログラム名に置き換えます。
Microsoft Dynamics GP にサインインします。
状態
Microsoft は、「適用対象」セクションに記載されている Microsoft 製品の問題であることを確認しました。 この問題は、修正される予定はありません。