この記事では、Workplace Join 操作を実行しようとしたときに "ユーザーが職場に参加できるデバイスの最大数に達しました" というエラーが発生する問題について説明します。
元の製品バージョン: Windows Server 2012 R2 Datacenter、Windows Server 2012 R2 Standard、Windows 8.1 Enterprise、Microsoft Entra ID
元の KB 番号: 3045379
現象
ユーザーが WIndows デバイスで Workplace Join 操作を実行しようとすると、次のメッセージが表示されます。
現在のサインイン情報を使用していること、および職場でこの機能が使用されていることを確認します。 また、職場への接続が現在機能していない可能性があります。 しばらくしてからやり直してください。
さらに、管理者は、イベント ビューアーで次のイベントの詳細を表示できます。
イベント ID:200
ログ名: Microsoft-Windows-Workplace Join/Admin Source: Microsoft-Windows-Workplace Join Level: Error Description: The maximum number of devices that can be joined to the workplace by the user has been reached.
登録サービス URI:https://enterpriseregistration.windows.net/EnrollmentServer/DeviceEnrollmentWebService.svc
原因
この問題は、ユーザーがデバイスの最大数に参加し、指定されたクォータを満たしているために発生します。
解決方法
この問題を解決するには、クォータの構成を確認します。 次に、ユーザーが以前に登録したデバイスの数を確認します。 クォータに達した場合は、該当するシナリオに応じて、次の手順に従います。
- ユーザーが Microsoft Entra ID への Workplace Join を実行しようとしている場合
- ユーザーのデバイスを削除します。
- Azure portal にサインインするか、会社の管理者としてMicrosoft 365 管理センターから Microsoft Entra ID コンソールを起動します。
- ユーザーが参加を試みているディレクトリに移動します。
- Usersを見つけて、Workplace Join 操作を実行できないユーザーを見つけます。
- Devicesを見つけます。
- 一覧を確認して、削除できるデバイスを決定します。 次に、[デバイスの削除 ] をクリック。
- 登録済みデバイス クォータを増やします。
- Azure portal にサインインするか、会社の管理者としてMicrosoft 365 管理センターから Microsoft Entra ID コンソールを起動します。
- ユーザーが参加を試みているディレクトリに移動します。
- Devicesを見つけて、Device Settingsを見つけます。
- ユーザーあたりのデバイス数の最大値設定を大きな値に変更します。
- ユーザーのデバイスを削除します。
- ユーザーがローカル Active Directory サイトへの Workplace Join を実行しようとしている場合
- ユーザーのデバイスを削除します。
- Windows PowerShell スクリプトを使用して、デバイスを識別し、ユーザーに関連付けられているデバイスを削除します。
- Registered Device Quota の値を増やします。
AD FS サーバーにサインインします。
管理者特権で Windows PowerShell を実行します。
次のコマンドを実行してクォータを増やします。
Set-ADFSDeviceRegistration -DevicesPerUser [0 - 1000]
たとえば、次のコマンドを実行して、ユーザーのデバイス数を 10 に設定します。
Set-ADFSDeviceRegistration -DevicesPerUser 10
- ユーザーのデバイスを削除します。
DRS イベント ログを確認して、ユーザーがデバイスの容量に達したことを確認することもできます。
DRS サーバーでイベント ビューアーを開きます。
場所を参照します。
Applications and Services Logs\Device Registration Service\DRS\Admin
イベント ID 125 を探します。 次のようになります。
ユーザー 'user@domain.com : GUID' は、種類が 'device_type' 理由 'DeviceCapReached' のデバイスを登録する資格がありません。
詳細
トラブルシューティングの詳細については、「Workplace Join の問題のトラブルシューティング Diagnostic loggingを参照してください。
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