次の方法で共有


Microsoft Graph を使用してオブジェクトを管理するときの 404 エラー

この記事では、Microsoft Graph を使用して作成した Microsoft Entra オブジェクトを管理しようとしたときに発生する 404 (オブジェクトが見つかりません) エラーの解決策を示します。

現象

Microsoft Graph を使用して、Microsoft Entra ID でユーザー、グループ、アプリケーションなどのオブジェクトを作成するとします。 オブジェクトの作成直後にオブジェクトの取得、更新、修正プログラムの適用など、オブジェクトを管理しようとすると、404 (オブジェクトが見つかりません) エラーが発生します。 

原因

Microsoft Entra ID アーキテクチャでは、すべてのデータが地理的に分散されたデータ センター間でレプリケートされます。 この問題は、新しく作成されたオブジェクトをすべてのデータ センターに反映するレプリケーションの遅延が原因で発生します。 このレプリケーション プロセスの完了には数分かかる場合があります。

次の図に示すように、アプリケーションが Microsoft Entra ID でユーザーを作成するように Microsoft Graph 経由で要求を行うと、サービスはレプリケーション プロセスを開始し、そのユーザーのオブジェクトを返します。これには、ユーザーの ID と、要求で使用されるその他の関連データが含まれます。 アプリケーションがこのユーザーをすぐに更新しようとすると、新しいユーザー オブジェクトでまだ更新されていないレプリカに接続される可能性があります。 そのため、ユーザーがそのレプリカで見つからないため、404 エラーが発生します。

404 エラーの原因を説明する図。

ソリューション

この問題を解決するには、しばらく待ってから更新要求を再試行してください。 再試行後も 404 エラーが発生する場合は、待機時間を 2 倍にして、もう一度やり直してください。 レプリケーションに十分な時間を確保することで、このエラーが再び発生するのを防ぐことができます。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。