現象
ユーザーが Microsoft Entra ID 認証を使用するアプリケーションにサインインしようとすると、次のエラー メッセージが表示されます。
AADSTS50173: The provided grant has expired due to it being revoked, a fresh auth token is needed. The user might have changed or reset their password. The grant was issued on '{authTime}' and the TokensValidFrom date (before which tokens are not valid) for this user is '{validDate}'.
原因
このエラーは、認証に使用される更新トークンが取り消された場合に発生します。 この問題は、次の場合に発生します。
- ユーザーが自分のパスワードを変更またはリセットします。
- 更新トークンの有効期限が切れます。
- 管理者が更新トークンを取り消します。
詳細については、以下を参照してください:
Resolution
この問題を解決するには、該当する手順に従います。
ユーザー向け
問題が発生したアプリケーションで、キャッシュされたトークン情報を再認証またはクリアするオプションを見つけようとします。 これらのアクションは、サインアウトしてアプリケーションにサインインし直すことでも実行できます (この手順が該当する場合、または使用可能な場合)。
アプリケーション開発者向け
アプリケーションで Microsoft Authentication Library (MSAL)を使用している場合は、このガイダンス 従って MSAL のエラーと例外を処理します。
アプリケーションで MSAL を使用していない場合は、このガイダンスに従って MSAL でエラーと例外を し同様の方法をアプリケーションに実装してみてください。 目標は、ユーザーに再認証を要求し、新しいトークンを取得することです。
詳細
認証と承認のエラー コードの完全な一覧については、「microsoft Entra 認証と承認のエラー コードを参照してください。
個々のエラーを調査するには、 https://login.microsoftonline.com/errorに移動します。
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