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エラー AADSTS700003 - テナント '<TenantName>' ディレクトリにデバイス オブジェクトが見つかりませんでした

この記事では、Microsoft Entra ID に統合されているアプリケーションにサインインしようとしたときに発生する "AADSTS700003" エラーを解決する方法について説明します。

現象

Microsoft Entra ID に統合されているアプリケーションにサインインしようとすると、"AADSTS700003" エラーが表示され、次のいずれかのエラー メッセージが表示されます。

  • テナント '<TenantName>' ディレクトリにデバイス オブジェクトが見つかりませんでした。

  • 組織がこのデバイスを削除しました。

原因

この問題は、ホーム テナントでデバイス オブジェクトが削除されるために発生します。 デバイスが削除されると、"デバイスの削除" アクティビティの種類が Microsoft Entra 監査ログに記録されます。 Microsoft Entra ID には、ユーザー デバイスを登録または参加させる方法が 3 つあります。

  • Microsoft Entra 登録済み
  • Microsoft Entra 参加済み
  • Microsoft Entra ハイブリッド参加済み

デバイスの登録または参加により、 デバイス ID が作成。 このデバイス ID は、デバイス ベースの条件付きアクセス ポリシー、Microsoft Intune での Mobile デバイス管理などのシナリオで使用。 AADSTS700003 エラーが発生すると、デバイス オブジェクトがテナントに見つかりません。

ソリューション

ホーム テナント管理者に問い合わせて、デバイス オブジェクトが削除されるタイミングと理由を判断します。 次の表に示すように、デバイスの登録/参加の種類に応じて、対応するアクションを実行します。

デバイスの参加の種類 動作
Microsoft Entra 登録済み Windows 10/11 Microsoft Entra 登録済みデバイスの場合は、 Settings>Accounts>Access Work or School に移動します。 画面で職場または学校アカウントを選択します。 Disconnect を選択してデバイスを切断します。 次に、デバイスをもう一度 Microsoft Entra ID に登録します。

iOS および Android の場合は、Microsoft Authenticator アプリケーションを使用し、 Settings>Device Registration>Unregister デバイスを選択できます。 次に、デバイスをもう一度 Microsoft Entra ID に登録します。

macOS の場合は、Microsoft Intune ポータル サイト アプリケーションを使用して、管理対象からデバイスを登録解除して、登録を削除することができます。 次に、デバイスをもう一度 Microsoft Entra ID に登録します。

詳細については、「 Microsoft Entra register FAQ」を参照してください。
Microsoft Entra 参加済み Windows デバイスで管理権限を持つ PowerShell コンソールを開き、 dsregcmd /forcerecovery コマンドを実行します。 [ サインイン を選択して、Microsoft Entra ID アカウントでサインインします。
Microsoft Entra ハイブリッド参加済み Windows デバイスで管理権限を持つ PowerShell コンソールを開き、 dsregcmd /leave コマンドを実行します。 次に、デバイスを再起動し、ドメイン資格情報を使用してデバイスにサインインします。

詳細

認証と承認のエラー コードの完全な一覧については、「microsoft Entra 認証と承認のエラー コードを参照してください。

個々のエラーを調査するには、 https://login.microsoftonline.com/errorに移動します。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。