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自動アップグレード後に Microsoft Entra Connect が正常に動作しない

この記事では、Microsoft Entra Connect が部分的にしかアップグレードされないか、パスワード同期とパスワード ライトバック機能が無効になっている問題について説明します。

元の製品バージョン: Microsoft Entra ID
元の KB 番号: 4038479

現象

Microsoft Entra Connect 1.1.443.0 以前のバージョンを実行すると、次のいずれかの問題が発生します。

  • Microsoft Entra Connect は部分的にのみアップグレードされ、スケジューラは中断され、自動同期サイクルは発生しません。
  • Microsoft Entra Connect が正しくアップグレードされ、スケジューラが有効になり、オブジェクトの変更が Microsoft Entra ID に正しく同期されます。 ただし、パスワード同期機能またはパスワード ライトバック機能は無効になっています。

原因

Microsoft Entra Connect の自動アップグレード機能の問題により、ハンドルされない例外が原因で Microsoft.Azure.ActiveDirectory.Synchronization.Upgrader.exe プロセスが終了します。 そのため、自動アップグレードは完了しません。 確認する手順は次のとおりです。

手順 1: 自動アップグレードが最近 Microsoft Entra Connect のアップグレードを試みたかどうかを判断する

%ProgramData%\AADConnect フォルダー内のログ ファイルを調べます。 タイトルが SyncEngine-AutoUpgrader-[Date]-[Time].log のログ ファイルは、自動アップグレードが発生した時刻を示します。

自動アップグレードの時刻を示すログ ファイルのスクリーンショット。

手順 2: Microsoft Entra Connect が部分的にアップグレードされているかどうかを判断する

Microsoft Entra Connect ウィザードを実行します。 Microsoft Entra Connect が部分的にアップグレードされた場合は、Microsoft Entra Connect のアップグレードを求められます。

Microsoft Entra Connect のアップグレードを求める Microsoft Entra Connect ウィザードのスクリーンショット。

手順 3: インストールされているバージョンの Microsoft Entra Connect とサーバー構成のバージョンを比較する

自動アップグレード中に、Microsoft Entra Connect の現在のインストールがアップグレードされ、サーバー構成のバージョンが更新されます。 2 つのバージョンが一致しない場合、Microsoft Entra Connect は部分的にのみアップグレードされます。

インストールされている Microsoft Entra Connect のバージョンを確認するには、コントロール パネルで Programs and Features 項目を開き、Microsoft Entra Connect のバージョン番号を確認します。

サーバー構成で Microsoft Entra Connect のバージョンを確認するには、Windows PowerShell で次のコマンドを実行し、 Microsoft.Synchronize.ServerConfigurationVersion プロパティの値を探します。

(Get-ADSyncGlobalSettings).Parameters | select Name,Value

スクリーンショットは、サーバー構成の Microsoft Entra Connection バージョンを示しています。

次のコマンドを実行して、スケジューラの状態を確認します。

Get-ADSyncScheduler

SchedulerSuspended の値が True の場合、スケジューラは中断されます。

Microsoft Entra Connect のスケジューラの状態を示すスクリーンショット。

手順 4: パスワード同期とパスワード ライトバックが有効になっていることを確認する

Microsoft Entra Connect が正しくアップグレードされている場合は、Microsoft Entra Connect ウィザードを開き、 ソリューションの確認 を選択して、パスワード同期とパスワード ライトバック機能が有効になっていることを確認します。

回避策

この問題を回避するには、次の手順に従ってください。

  1. Microsoft Entra Connect ウィザードを起動し、 アップグレードを選択します。
  2. アップグレードが完了したら、インストールされているバージョンの Microsoft Entra Connect がサーバー構成のバージョンと一致することを確認します。
  3. 以前にパスワード同期機能またはパスワード ライトバック機能を有効にしている場合は、アップグレードが完了した後も機能が有効なままであることを確認します。
  4. アップグレード後にいずれかの機能が無効になっている場合は、Microsoft Entra Connect ウィザードで Customize 同期オプション を選択し、機能を手動で有効にします。

お問い合わせはこちらから

質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。