この記事では、Microsoft Entra Connect Health for Sync で CPU 使用率が高くなる問題を解決する方法について説明します。
元の製品バージョン: Microsoft Entra ID
元の KB 番号: 4346822
現象
Microsoft Entra Connect Health for Sync 監視エージェントを実行するコンピューターでは、パフォーマンスが低下し、CPU 使用率が高くなります (最大 100%) タスク マネージャーで、 Microsoft.Online.Reporting.MonitoringAgent.Startup プロセスによって CPU 使用率が高くなっていることがわかります。
Note
この問題は、Microsoft Entra Connect Health の特定のバージョンまたはオペレーティング システムのバージョンに限定されるものではありません。
原因
この問題は、.NET Framework 4.7.2 用の June 2018 更新プログラムがコンピューターにインストールされており、Microsoft Entra Connect Health for Sync 監視エージェントがこの更新プログラムを完全にサポートしていないために発生します。
次の .NET Framework の更新により、監視エージェントによる CPU 使用率の高い問題が発生します。
.NET Framework の更新 | システム バージョン |
---|---|
KB4338420 | Windows Server 2008 |
KB4338606 | Windows Server 2008 R2 |
KB4054542 | Windows Server 2012 |
KB4054566 | Windows Server 2012 R2 |
KB4054590 KB4338814 KB4338419 KB4338605 KB4345418 | 全般 |
解決方法
AD DS と AD FS の Connect Health の場合
Active Directory ドメイン Services (AD DS) と Active Directory フェデレーション サービス (AD FS) (AD FS) のこの問題を解決するには、2018 年 7 月にリリースされた新しい Microsoft Entra Connect Health エージェント バージョン 3.1.7.0 をインストールします。 エージェントは、 Connect Health のパブリック ドキュメントからダウンロードできます。
Microsoft Entra Connect の場合
Microsoft Entra Connect のこの問題を解決するには、 最新バージョンの Microsoft Entra Connect をインストールします。
お問い合わせはこちらから
質問がある場合やヘルプが必要な場合は、サポート要求を作成するか、Azure コミュニティ サポートにお問い合わせください。 Azure フィードバック コミュニティに製品フィードバックを送信することもできます。