この記事では、セキュリティ グループがオンプレミス AD での同期によって無効になった後もメールが有効なままになる問題を解決する方法について説明します。
元の製品バージョン: Microsoft Entra ID
元の KB 番号: 4096314
現象
以下のシナリオについて考えてみます。
- オンプレミスの Active Directory (オンプレミス AD) で指定された電子メール アドレスを持つセキュリティ グループがある。
- セキュリティ グループは Microsoft Entra ID に同期されます。
- オンプレミス AD のセキュリティ グループからメール アドレスを削除します。
- 同期を実行します。 このシナリオでは、セキュリティ グループはメールが有効なままであり、Microsoft Entra ID で割り当てられた元の電子メール アドレスが保持されます。
原因
メールが有効なセキュリティ グループが Microsoft Entra ID に同期されると、元のドメイン (onmicrosoft.com
) を使用する電子メール アドレスがセカンダリ メール アドレスとしてグループに追加されます。 プライマリ メール アドレスを削除すると、元のドメインを持つメール アドレスがプライマリ メール アドレスになります。
この問題の影響を次に示します。
- 影響を受けるグループは、オンプレミス ユーザーのグローバル アドレス一覧 (GAL) に存在しないため、ユーザーは電子メールの送信時に提出された From でグループを選択できません。
- Exchange Online ユーザーの場合、影響を受けるグループは GAL で選択できます。 ただし、グループのメール アドレスが
alias@contoso.onmicrosoft.com
に変更されたため、メールは受信者に届きません。 - オンプレミスのユーザーは、影響を受けるグループを使用して、共有予定表へのアクセスなどのアクセス許可を設定することはできません。
- Exchange Online ユーザーの場合、影響を受けるグループを使用して予定表へのアクセスを設定できます。
回避策
この問題を回避するには、以下のいずれかの方法を使用します。
管理ポータルからセキュリティ グループを削除し、同期をもう一度実行します。
同期されていない (除外された) 別の組織単位 (OU) にセキュリティ グループを移動します。 これを行うと、グループはクラウドから削除されます。 次に、グループを元の OU に戻します。
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