元の製品バージョン: Office 365 Identity Management、Microsoft Entra ID
元の KB 番号: 4054462
現象
Microsoft Entra Connect をアップグレードしようとすると、次のエラー メッセージが表示されます。
Azure Active Directory 同期からのアップグレード中にエラーが発生しました。同期サービスをアップグレードできません。 詳細については、イベント ログを参照してください。
詳細なイベント ログは次のようになります。
Date/Time[ 12] [INFO] ServiceControllerProvider: StartService status: Running Date/Time[ 12] [ERROR] Error during sync engine upgrade. System.Exception: 同期サービスをアップグレードできません。 詳細については、イベント ログを参照してください。 ---> Microsoft.Azure.ActiveDirectory.Client.Framework.ProcessExecutionFailedException: msi パッケージ 'Synchronization Service.msi' のインストール中にエラーが発生しました。 完全なログは、'C:\ProgramData\AADConnect\Synchronization Service_Install-DateTime.log' で使用できます。
Action startTime: DetectServiceAccount。 CustomAction DetectServiceAccount から実際のエラー コード 1603 が返されました (サンドボックス内で翻訳が行われる場合、これは 100% 正確ではない可能性があります)、Action endedTime: DetectServiceAccount。 Return value 3. Action endedTime: INSTALL。 Return value 3. MSI (秒) (14:AC)時間: 注: 1: 1708 MSI (s) (14:AC)時間: 製品: Microsoft Entra Connect 同期サービス -- インストール操作に失敗しました。 MSI (秒) (14:AC)時間: Windows インストーラーによって製品がインストールされました。 製品名: Microsoft Entra Connect 同期サービス。 製品バージョン: 1.1.614.0。 製品言語: 1033。 製造元: Microsoft Corporation。 インストールの成功またはエラーの状態: 1603。 MSI (s) (14:AC)Time: Deferring clean up of packages/files, if any exist MSI (s) (14:AC)Time: MainEngineThread is returning 1603 MSI (s) (14:80)Time: RESTART MANAGER: Session closed.
原因
基になるサービス アカウントは、Domain\SamAccountName の代わりにユーザー プリンシパル名 (UPN) を使用して構成されました。
解決方法
この問題を解決するには、次の手順に従ってください。
- Microsoft Entra Connect サーバーでサービス コンソールを起動します。
- Microsoft Azure AD Sync サービスを見つけて、サービスを右クリックします。
- [プロパティ]、[ログオン] の順に選択します。
- UPN を使用する代わりに、ドメイン \SamAccountName を使用してアカウントを設定します。
- [適用] を選択して、[OK] を選択します。
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