更新プログラムをインストールする際のエラー 0x800f0831
この記事では、累積的な更新プログラムをインストールするときに 0x800f0831 エラーが発生する問題を修正します。
元の製品バージョン: 構成マネージャー (現在のブランチ)、Windows Server Update Services
元の KB 番号: 4494631
症状
特に累積的な更新プログラムなど、Windows 更新プログラムをインストールしようとすると次のエラー メッセージが表示されます。
致命的: 0x800f0831エラーの CBS
この問題は、Microsoft Update にアクセスできない場合に発生する可能性が高くなります。
さらに、CBS ログで次のようなエラー メッセージが表示されます。
ストア破損、パッケージのマニフェストがありません。
パッケージの解決に失敗しました [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
パッケージが原因のストア破損フラグをマークします: [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
パッケージの解決に失敗しました [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
再評価のための次のパッケージを取得できませんでした [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
実行チェーンの実行に失敗しました。 [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
単一フェーズの実行を処理できませんでした。 [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
WER: パッケージのエラー レポートの生成: 状態: 0x800f0831、 失敗ソース: 実行、開始状態: ステージング済み、ターゲット状態: インストール済み、クライアント ID: DISM パッケージ マネージャー プロバイダー
Note
は、インストールできないパッケージを表します。 は、マニフェストが存在しないパッケージを表します。
原因
この問題は、インストールできない更新プログラムに以前の更新プログラム パッケージのマニフェストが必要であるために発生します。
解決方法
この問題を解決するには、以下のいずれかの方法を使用します。
方法 1: DISM コマンドを使用してコンポーネント ストアを修復する
DISM RestoreHealth
コマンドを使用してコンポーネント ストアを修復するには、次の手順に従います。
管理者特権のコマンド プロンプトを開き、コマンド を実行します。
DISM /ONLINE /CLEANUP-IMAGE /SCANHEALTH
DISM /ONLINE /CLEANUP-IMAGE /CHECKHEALTH
DISM /ONLINE /CLEANUP-IMAGE /RESTOREHEALTH
Sfc /Scannow
デバイスを再起動します。
方法 2: 部分的にインストールされたコンポーネントのペイロードを使用して手動で修復する
- [Microsoft Update カタログ] に移動します。
- [検索] ボックスに、のパッケージ ID を入力します。
- 検索結果でオペレーティング システムに適切に適用する更新プログラムを検索し、[ダウンロード] ボタンを選択します。
- [Microsoft Update Catalog]\(Microsoft Update カタログ\) ウィンドウで、更新プログラムをダウンロードするファイルのリンクを選択します。
- ダウンロード プロセスの完了後に [閉じる] を選択します。 指定した場所に、更新プログラム パッケージを含むフォルダーが見つかります。
- フォルダーを開き、更新プログラム パッケージをダブルクリックして更新プログラムをインストールします。