この記事では、Microsoft Dynamics 365 App for Outlook で追跡されたメールまたは予定が追跡保留中として表示される問題の解決策を示します。
適用対象: Dynamics 365 App for Outlook
元の KB 番号: 4345569
現象
Microsoft Dynamics 365 App for Outlook を使用してメールまたは予定を追跡する場合、メールは Microsoft Dynamics 365 には表示されません。 Microsoft Dynamics 365 App for Outlook でアイテムを表示すると、アイテムは Track pending... として表示されます。
原因
アイテムが [追跡保留中] として表示され、最終的に Microsoft Dynamics 365 で作成され、[追跡済み] に切り替わる場合は、これが予想される可能性があります。 D365 App for Outlook ユーザー ガイドの「同期と追跡」セクションを確認してアイテムがアプリによってすぐに作成されることが想定されているか、またはサーバー側同期がアイテムの作成/追跡を担当するかどうかを確認します。 アイテムが [追跡済み] ではなく [保留中の追跡] と表示される場合は、次の同期サイクルで最大 15 分かかる可能性があるサーバー側同期によってアイテムが処理されることを示します。
アイテムが 20 分を超えて追跡保留中として表示される場合は、「解決」セクションを参照してください。
Resolution
アイテムが 20 分を超えて追跡保留中と表示される場合は、Dynamics 365 のユーザーのメールボックス レコードがサーバー側同期を使用するように構成されており、メールボックスが正常にテストされて有効になっていることを確認します。
- システム管理者ロールを持つユーザーとして Dynamics 365 にアクセスします。
- Settingsに移動し、Email Configuration を選択します。
- [メール ボックス 選択し ビューを Active Mailboxes に変更します。
- ユーザーのメールボックス レコードを見つけて開きます。
- [電子メールの受信] オプションが [サーバー側同期または電子メール ルーターに設定されていることを確認。 アイテムが予定の場合は、[予定]、[連絡先]、[タスク] の設定も確認します。
- [電子メールの状態]がまだ Success として表示されない場合はテストとメールボックスの有効化を選択し、ダイアログに表示されるチェック ボックスをオンにします。
- メールボックスのテストが成功しない場合は、 Alerts セクションのメッセージを確認します。 アラートに [詳細情報] リンクが含まれている場合は、このリンクを選択して詳細を確認します。
メールボックスが既にテストされ、正常に有効になっている場合は、メールボックス レコード内の [アラート] セクションを確認します。 サーバー側同期で Microsoft Dynamics 365 でアイテムを作成することが予想された場合は、[アラート] セクションにエラーが表示されます。
注:
[アラート] セクションにエラーが表示されない場合は、 Settings>Email Configuration>Email Configuration Settings に移動します。 構成アラート セクションで、Error と Warning オプションが選択されていることを確認します。 これらのオプションがまだ選択されていない場合は、これらのオプションを有効にして OK を選択します。 次に、別のアイテムの問題を再現して、アイテムが 20 分以上 Track pending として表示された後にエラーまたは警告がログに記録されるかどうかを確認します。