この記事は、Microsoft Dynamics 365 App for Outlook を使用または開こうとすると発生するエラーを解決するのに役立ちます。
適用対象: Dynamics 365 App for Outlook
元の KB 番号: 4563997、4229661
現象 1
Dynamics 365 App for Outlook を使用しようとすると、次のようなエラーが表示されます。
必要な特権である (prvReadOrganization) が不足しており、特定の機能が制限されます。 必要なアクセス権を取得するには、管理者に問い合わせてください。
原因
このエラーは、メールボックス レコードに関連付けられているユーザーが Dynamics 365 App for Outlook を使用するための十分な権限を持っていない場合に発生します。
現象 2
Dynamics 365 App for Outlook を開くと、次のエラーが表示されます。
申し訳ございません。
現在のユーザー ロールには必要なアクセス許可がないため、Dynamics 365 App for Outlook を表示できません。 Dynamics 365 App for Outlook ソリューションに必要なセキュリティ ロールが割り当てられている場合は、管理者に問い合わせてください。
[さらに表示] を選択した場合追加の詳細には、次の情報が含まれます。
エラー: AppforOutlookModule ID を取得するアクセス許可がありません
トレース: エラー: 新しい ... で AppforOutlookModule ID を取得するアクセス許可がありません。
原因
このエラーは、Dynamics 365 セキュリティ ロールが Dynamics 365 App for Outlook で使用されるアプリ モジュールにアクセスできない場合に発生します。
決議
これらの問題を解決するには、次のいずれかのオプションを使用します。
オプション 1: "Dynamics 365 App for Outlook User" セキュリティ ロールを割り当てる
Dynamics 365 App for Outlook User セキュリティ ロールは、Dynamics 365 App for Outlook を使用する必要があるユーザーに割り当てることができます。 このセキュリティ ロールは、ビルド 9.1.0.4206 以降から使用できます。 このオプションにより、ユーザーは Dynamics 365 App for Outlook にアクセスするために必要な基本的な特権を持つことができます。
オプション 2: カスタム セキュリティ ロールに特権を割り当てる
必要な特権を含むようにセキュリティ ロールをカスタマイズする場合は、Dynamics 365 App for Outlook を使用するために必要な権限の一覧については、「 詳細情報 」セクションを参照してください。
重要
カスタム セキュリティ ロールは、既定では Dynamics 365 アプリ モジュールにアクセスできません。 「 手順 3: セキュリティ ロールへのアクセスを提供する も必要です。
詳細
次の表に、Dynamics 365 App for Outlook を使用するために必要な権限と、権限が見つかるセキュリティ ロールのタブを示します。
システム管理者ロールを持つユーザーは、 Settings>Security>Security Roles に移動することで、セキュリティ ロールを見つけて変更できます。
特定のユーザーに割り当てられているロールを表示するには、 Settingsに移動し、 Security を選択し、 Users を選択し、特定のユーザー レコードを選択して、 管理ロールを選択します。
特権名 | エンティティ | セキュリティ ロール内の場所 (タブ) |
---|---|---|
prvReadEmailServerProfile | メールサーバープロファイル | ビジネス管理 |
prvReadRole | セキュリティ・ロール | ビジネス管理 |
prvReadUser | ユーザー | ビジネス管理 |
prvWriteMailbox | メールボックス | ビジネス管理 |
prvReadMailbox | メールボックス | ビジネス管理 |
prvReadOrganization | 組織 | ビジネス管理 |
prvSyncToOutlook (exchangesyncidmapping) | Outlook に同期 | ビジネス管理 > プライバシー関連の権限 |
prvUseOfficeApps | Dynamics 365 App for Outlook の使用 | ビジネス管理 > プライバシー関連の権限 |
アカウントに追加する | アカウント | コア レコード |
prvReadAccount | アカウント | コア レコード |
prvDeleteActivity | 活動 | コア レコード |
prvAppendActivity | 活動 | コア レコード |
prvWriteActivity | 活動 | コア レコード |
prvCreateActivity | 活動 | コア レコード |
prvReadActivity | 活動 | コア レコード |
prvAppendToActivity | 活動 | コア レコード |
prvShareActivity | 活動 | コア レコード |
prvAppendToContact | お問い合わせ | コア レコード |
prvReadContact | Contact | コア レコード |
prvCreateContact | 連絡 | コア レコード |
prvReadUserQuery | 保存されているビュー | コア レコード |
prvReadAppModule | モデル駆動アプリ | カスタマイズ |
prvReadAttribute | フィールド | カスタマイズ |
prvReadEntity | エンティティ | カスタマイズ |
prvReadRelationship | リレーションシップ | カスタマイズ |
システムアプリケーションメタデータを読み込む | システム アプリケーション メタデータ | カスタマイズ |
prvReadSystemForm | システム フォーム | カスタマイズ |
prvReadUserApplicationMetadata | ユーザー アプリケーション メタデータ | カスタマイズ |
prvReadQuery | ビュー | カスタマイズ |
prvReadWebResource | Web リソース | カスタマイズ |
空き状況を検索 | 使用可能性の検索 | サービス管理 > その他の権限 |
次の表に、Dynamics 365 App for Outlook フォーム内で使用される既定のビューの一部を表示するために必要な追加の特権を示します。 これらの特権がないと、ユーザーは、レコードの予期されるビュー (サブグリッド) ではなく、次のエラーが表示されることがあります。
これらのレコードにアクセスするためのアクセス許可がありません。 Microsoft Dynamics 365 管理者に問い合わせてください。
特権名 | エンティティ | セキュリティ ロール内の場所 (タブ) |
---|---|---|
prvReadIncident | ケース | サービス |
prvReadOpportunity | 機会 | コア レコード |
prvReadCompetitor | 競合企業 | 営業 |
prvReadConnection | つながり | コア レコード |