この記事では、 Microsoft Dynamics 365 サーバーに接続できないため、Outlook 用 Microsoft Dynamics 365 アプリを使用できない問題の解決策 説明します。
適用対象: Dynamics 365 App for Outlook
元の KB 番号: 4341413
現象
Microsoft Dynamics 365 App for Outlook を使用しようとすると、次のメッセージが表示されます。
"Microsoft Dynamics 365 サーバーに接続できません。 アプリを閉じてから再度開いてください。"
[さらに表示 ] を選択すると次のメッセージが表示されることがあります。
"クライアント ローダーのタイムアウト"
Outlook Web Access (OWA) でアプリを使用すると、画面の下部に次のプロンプトが表示されることがあります。
"
dynamics.com
がコンピューター上で追加の記憶域を使用することを許可しますか?
Internet Explorer ブラウザーのキャッシュをクリアすると、このエラーは解決されているように見えますが、最終的には返されます。
原因
Microsoft は、キャッシュできるデータの量を制限するように Internet Explorer が構成されているため、このエラーが発生する可能性がある問題を認識しています。 Internet Explorer を使用してアプリを表示している場合は、これがエラーの原因である可能性があります。 Outlook Desktop を使用してこのエラーが発生した場合、Outlook は常に Internet Explorer を使用してアプリを表示します。
Resolution
Microsoft は、この問題を回避するために変更に取り組んでいます。 それまでの間は、次の手順を回避策として使用できます。
オプション 1 - Internet Explorer オプション内のデータベース制限を増やす
オペレーティング システムのバージョンによっては、Internet Explorer の設定内で制限を変更できる場合があります。 Windows 10 を使用している場合、このオプションは表示されず、代わりにオプション 2 を使用できます。
- Internet Explorer を開きます。
- 右上隅にある歯車アイコンを選択し、 Internet オプションを選択します。
- [履歴] セクションの [General タブで、Settings を選択します。
- キャッシュとデータベース タブを選択します。
- [Web サイトのキャッシュまたはデータベースが超えたときに表示されない が表示される場合は 値を 200 に変更し OK 選択。 または、Web サイトの一覧から
dynamics.com
を選択し、 Exceed limit を選択することもできます。 これらのオプションが表示されない場合は、オプション 2 に進みます。 - Internet Explorer の履歴とキャッシュをクリアします。 詳細な手順については、「 Internet Explorer で閲覧履歴を表示および削除するを参照してください。
オプション 2 - レジストリ内のデータベース制限を増やす
重要
このタスクには、レジストリを変更する手順が含まれます。 ただし、レジストリを正しく変更していない場合、重大な問題が発生する可能性があります。 したがって、次の手順を注意深く実行してください。 保護のために、レジストリを変更する前に、バックアップします。 その後、問題が起こった場合は、レジストリを復元できます。 レジストリをバックアップおよび復元する方法の詳細については、「Windows でレジストリをバックアップおよび復元する方法」を参照してください。
許可されるキャッシュ制限を増やすには、次のレジストリ エントリを作成します。
サブキー: HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue
名前: MaxTrustedDomainLimitInMB
種類: REG_DWORD
データ: 200
このレジストリ エントリを作成するには、次の手順に従います。
[スタート] ボタンを選択し、[ファイル名を指定して実行] を選択します。次に、「regedit」と入力し、[OK] を選択します。
次のレジストリ サブキーを見つけて選択します。 この場所へのパスが存在しない場合は、前述のキーを作成する必要があります。
HKEY_LOCAL_MACHINE\Software\Policies\Microsoft\Internet Explorer\BrowserStorage\IndexedDBValue
IndexedDBValueを右クリックし、New をポイントし、DWORD 値を選択します。
[ New Value #1 ボックスに「 MaxTrustedDomainLimitInMB」と入力し、Enter キーを押します。
MaxTrustedDomainLimitInMBを右クリックし、Modify を選択します。
Decimalを選択し、「200」と入力しOK 選択。
レジストリ エディターを終了し、コンピューターを再起動します。
Internet Explorer の履歴とキャッシュをクリアします。 詳細な手順については、「 Internet Explorer で閲覧履歴を表示および削除するを参照してください。
詳細
このエラーには、複数の原因が考えられます。 これで問題が解決しない場合は、次の記事を参照して、その他の解決策を参照してください。
Dynamics 365 App for Outlook の使用時に"Microsoft Dynamics 365 サーバーに接続できません" というエラーが表示される