参照では、Dynamics 365内の特定のエンティティに対して期待どおりにレコードがフィルター処理されません
この記事では、入力したレコードに関連するレコードではなく、ルックアップですべてのレコードが表示される問題の回避策について説明します。
適用対象: Power Apps
元の KB 番号: 4603850
現象
ルックアップ コントロールに入力すると、入力したレコードに関連するレコードだけでなく、ビュー内のすべてのレコードが表示されます。 レコードをスクロールすると、テキストが検索テキストと一致すると、通常のように太字のレコード テキストが表示されます。
原因
この問題には、次の 2 つの原因が考えられます。
原因 1
この問題は、エンティティの クイック検索ビュー に "検索" 列がないために発生します。
ルックアップ ビューは、ルックアップ コントロール内に表示される列を決定しますが、[クイック検索ビュー - の検索] 列によって、ルックアップ コントロール内で検索される列が決まります。 基本的に、ルックアップ コントロールに値を入力すると、検索列内の一致が検索されます。 その後、一致するレコードが選択され、ルックアップ ビューによって決定された情報が表示されます。 すべてのレコードが表示される理由は、 クイック検索ビューに "検索" 列が設定されていないことです。
注:
クイック検索ビュー列は、クイック検索ビュー - の検索列と同じではありません。 クイック検索ビュー内には多数の列が存在する可能性がありますが、"検索" 列としてマークされていない場合、検索は期待どおりに機能しません。
表示される列と検索された列が異なる理由は、そのパフォーマンスです。 検索される列が少ないほど、検索をより高速に実行できます。 ただし、検索コントロールに多くの情報を表示して、適切なレコードを選択することが必要な場合があります。
"find" 列を追加する手順については、「 回避策 1」を参照してください。
原因 2
この問題は、参照コントロールで使用されているビューに文字列型の列がないために発生します。
参照コントロールでは、文字列以外の型の列をフィルター処理できません。 使用するビューには、テキスト、電子メール、電話、URL など、少なくとも 1 つの文字列型列が必要です。
文字列型列を追加する手順については、「 回避策 2」を参照してください。
回避策
この問題を回避するには、次のいずれかの回避策を使用します。
回避策 1
[ カスタマイズ] で、ルックアップ コントロールのエンティティの クイック検索ビュー に移動します。
[ 列の検索の追加] を選択します。
検索コントロール内で検索および照合する列を追加します。
変更を保存して発行します。
回避策 2
検索コントロールで使用されるビューに文字列型の列を追加する必要があります。
[ カスタマイズ] で、フィルター処理が中断されている参照コントロールで使用されるビューに移動します。
[ 列の追加] を選択します。
少なくとも 1 つの文字列型列を追加します。