この記事では、特定のセキュリティ設定が原因で Web オートメーションに Internet Explorer を使用するときにユーザーがエラーが発生する問題に対処します。
症状
Power Automate で 新しい Internet Explorer の起動 アクションを含むデスクトップ フローを実行すると、実行時に自動化が失敗し、次のエラー メッセージが表示されます。
IE の制御を取得できませんでした
原因
この問題は、Internet Explorer のセキュリティ設定が正しく構成されていないために発生する可能性があります。 具体的には、[ 保護モードを有効にする] 設定では、オートメーション ツールがブラウザーを制御できなくなる可能性があります。
解決策
- Internet Explorer を開きます。
- 設定>Internet オプションに移動します。
- [ セキュリティ ] タブに移動します。
- [ インターネット ] セクションで、[ 保護モードを有効にする ] チェック ボックスをオフにします。
- [ 適用>OK ] を選択して変更を保存します。
- Internet Explorer を閉じて再起動します。
詳細については、「 Power Automate でブラウザーを設定する」を参照してください。