この記事では、無人モードで実行したときに Web オートメーション アクションが失敗する問題を解決するための回避策について説明します。
症状
参加モードでは、Browser Automation グループの下の Web オートメーション アクションが正常に実行されます。 ただし、無人モードでは、これらのアクションは失敗します。
シナリオ 1: 新しい Microsoft Edge の起動、新しい Chrome の起動、または新しい Firefox の起動アクションが失敗する
新しい Microsoft Edge の起動、新しい Chrome の起動、または新しい Firefox の起動アクションが失敗し、次のエラーが表示されます。
Microsoft Edge/Chrome/Firefox の制御を想定できませんでした (Power Automate Web 拡張機能との通信に失敗しました)
このエラーは、次の理由で発生する可能性があります。
ブラウザーが起動せず、ブラウザー ウィンドウが表示されない
この問題を回避するには、ブラウザーの起動が無人モードでブロックされていないことを確認します。 一覧表示されているアクションを使用して確認し、ブラウザーが開き、ウィンドウが表示されていることを確認します。 対応するアクションを作成するには、次のコマンドをコピーし、 フロー デザイナーに貼り付けます。
Chrome の場合:
System.RunApplication.RunApplication ApplicationPath: $'''chrome''' CommandLineArguments: $'''<https://www.microsoft.com/>''' WindowStyle: System.ProcessWindowStyle.Normal ProcessId=> AppProcessId
Microsoft Edge の場合:
System.RunApplication.RunApplication ApplicationPath: $'''msedge''' CommandLineArguments: $'''<https://www.microsoft.com/>''' WindowStyle: System.ProcessWindowStyle.Normal ProcessId=> AppProcessId
ブラウザーが開き、ウィンドウが表示されている場合は、[ブラウザーの起動] アクションの "アタッチ" モードを使用します。
WebAutomation.LaunchEdge.AttachToEdgeByUrl TabUrl: $'''https://www.microsoft.com/''' AttachTimeout: 5 TargetDesktop: $'''{\"DisplayName\":\"Local computer\",\"Route\":{\"ServerType\":\"Local\",\"ServerAddress\":\"\"},\"DesktopType\":\"local\"}''' BrowserInstance=> Browser
Web ページがブラウザーに読み込むのに時間がかかりすぎる
この問題を回避するには、次の手順を実行します。
[ 新しい Microsoft Edge の起動]、[ 新しい Chrome の起動]、または [新しい Firefox の起動 ] アクションで、[ 詳細設定 ] セクションにある次のパラメーターの既定値を増やします。
- Web ページの読み込み時のタイムアウト (たとえば、 120 秒に設定)
- タイムアウト (たとえば、 120 秒に設定)
タイムアウトを大きくしても問題が解決しない場合は、次のアクションを使用してブラウザー インスタンスを取得します。
System.RunApplication.RunApplication ApplicationPath: $'''msedge''' CommandLineArguments: $'''<https://www.microsoft.com/>''' WindowStyle: System.ProcessWindowStyle.Normal ProcessId=> AppProcessId WAIT 120 WebAutomation.LaunchEdge.AttachToEdgeByUrl TabUrl: $'''https://www.microsoft.com/''' AttachTimeout: 30 TargetDesktop: $'''{\"DisplayName\":\"Local computer\",\"Route\":{\"ServerType\":\"Local\",\"ServerAddress\":\"\"},\"DesktopType\":\"local\"}''' BrowserInstance=> Browser
クラウド フローは、ブラウザー拡張機能がインストールされているユーザーとは異なるユーザーで実行されます
この問題を回避するには、クラウド フローを無人モードで実行しているユーザーにブラウザー拡張機能がインストールされていることを確認します。
ブラウザー拡張機能のインストールを確認するには、フロー デザイナーのツール>Browser 拡張機能オプションを参照してください。 詳細については、「 Power Automate ブラウザー拡張機能のインストール」を参照してください。
コンピューターの CPU 使用率が 100%に達し、Web 拡張機能のサービス ワーカーが起動するのを防ぎます
この問題を回避するには、フローが実行されるコンピューターに CPU リソースを増やします。 詳細については、「前提条件の」を参照してください。
シナリオ 2: その他の Web オートメーション アクションが "要素が見つかりません" エラーで失敗する
次の Web オートメーション アクションは、"要素が見つかりません" エラーで失敗する可能性があります。
- Web ページのリンクをクリックする
- Web ページにテキスト フィールドを設定する
- ウェブページ上のボタンを押してください
- Web 要素との対話を伴う任意の Web アクション。
原因
画面の解像度の不一致により、Web オートメーション アクションが失敗する場合があります。 無人モードでは、画面の解像度が、参加モードで使用される解像度と異なる場合があるため、Web 要素や UI のレンダリングが異なる場合があります (レスポンシブ レイアウトなど)。
問題解決策
この問題を回避するには、 無人モードでの画面解像度の設定に関するドキュメントの手順に従います。 このドキュメントでは、無人実行中に一貫した画面解像度を確保するために必要な構成とレジストリ キーの設定について説明します。