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デスクトップ用 Power Automateにサインインできない

この記事では、デスクトップ用 Power Automateのいくつかのサインイン関連の問題の解決策と回避策について説明します。

一般的なサインインまたはサインアウトの問題

デスクトップ用 Power Automateは、msalcache.bin3 という名前のファイルを使用してトークンを取得し、ユーザーを認証します。

サインインまたはサインアウト中にエラーが発生した場合は、このファイルを削除して、格納されているすべてのトークンを削除します。

ファイルを削除するには、[MSI インストール] または %localappdata%\Microsoft\Power Automate Desktop\Cache\Store[Microsoft Store のインストール] に%localappdata%\Microsoft\Power Automate Desktop\Cache\MSI移動します。

注:

AppData フォルダーがユーザー フォルダーに表示されない場合は、非表示のファイルを表示してみてください。

msalcache.bin3 ファイルを削除した後、Power Automate コンソールを閉じ、システム トレイから Power Automate を終了するか、Power Automate サービスを再起動してから、もう一度サインインしてみてください。

Web アカウント マネージャー (WAM) エラー

既定では、デスクトップ用 Power Automateは、オペレーティング システムに付属し、認証ブローカーとして機能する Windows コンポーネントである Web アカウント マネージャー (WAM) を介してユーザーを認証します。

WAM と関連するエラーの詳細については、「 Web アカウント マネージャー (WAM) で MSAL.NET を使用する」 および「 WAM で対話型を使用する」を参照してください。

リージョンの問題が間違っている

サインインする前に、[ リージョンの変更 ] オプションから正しいリージョンを選択していることを確認します。

Power Automate コンソールの [リージョンの変更] オプションを示すスクリーンショット。

ブラウザーが Cookie をブロックする

デスクトップ用 Power Automateにサインインすると、次のエラー メッセージが表示されます。

サインインできません。 現在、ブラウザーは Cookie をブロックするように設定されています。 Cookie によるこのサービスの使用を許可する必要があります。

解決方法

  1. [コントロール パネル>Internet Optionsセキュリティ>信頼済みサイト] > に移動します。

  2. 次の URL を追加します。

    • login.microsoft.com
    • login.windows.net
    • login.microsoftonline.com
    • secure.aadcdn.microsoftonline-p.com

接続の問題が原因でサインインできない

デスクトップ用 Power Automateにサインインすると、次のエラー メッセージが表示されます。

サインイン中に問題が発生しました。 後でやり直すか、管理者に問い合わせてください。

問題を確認する

Power Automate にサインインしてみてください。 想定どおりに動作する場合、問題は、デスクトップ用 Power Automateをホストするマシンのローカル ネットワーク構成に関連している必要があります。

解決方法

この問題を解決するための考えられる原因と手順の詳細については、「 デスクトップ フローを作成、編集、保存、または表示できない」を参照してください。

ログイン ウィンドウがポップアップし続ける

デスクトップ用 Power Automateへのサインイン中に、資格情報を入力すると、アカウントへのログイン ウィンドウが表示されます。 疑問符 (?) アイコンを選択して[Microsoft アカウントにログイン] でアカウント リセットすると、ログイン ウィンドウが消えます。

原因

別のプロセスでは、同じマシンで名前付きパイプ サーバーを実行している可能性があります。 このプロセスは、localhost エンドポイントを使用して昇格された権限で実行され、他のアプリケーションがこのエンドポイントの使用をブロックします。

別のプロセスが実行されているかどうかを識別するには:

  1. Sysinternals Suite をダウンロードします

  2. .zip ファイルをフォルダーに抽出します。

  3. 管理者としてコマンド プロンプトを実行します。

  4. Sysinternals Suite が抽出されたフォルダーに移動します。

  5. 次のコマンドを実行します。

    handle net.pipe
    

    注:

    このコマンドを実行すると、名前付きパイプとリッスンするアドレスを使用するプロセスの一覧が表示されます。

  6. 文字列を表示する EbmV0LnBpcGU6Ly8rLw== プロセスがあるかどうかを特定し、次のリンクを使用してプロセスをデコードします。

    https://www.base64decode.org/

    例:

    PAD.BrowserNativeMessageHost.exe pid: 21064 type: Section 464: \Sessions\1\BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rL0JST1dTRVJOQVRJVkVIT1NULzE2NjIwLzEv Microsoft.Management.Services.IntuneWindowsAgent.exe pid: 26708 type: Section 6AC: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rL0lOVFVORU1BTkFHRU1FTlRFWFRFTlNJT04vU1RBVFVTU0VSVklDRS8= PipesTest.Server.exe pid: 6540 type: Section 3AC: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rLw==
    

解決方法

この問題を解決するには、前の手順で特定したプロセスを停止するか、内部プロセスの場合は、 などの net.pipe://localhost/somethingより具体的なエンドポイントを使用します。

  • 別の方法として、デスクトップ用 Power Automateが閉じられている (タスク バーからも) ことを確認し、前の手順で特定したプロセスを強制終了してから、もう一度デスクトップ用 Power Automate再起動してください。

  • 他のソリューションが不可能な場合は、管理者として実行する実行可能ファイルデスクトップ用 Power Automate指定します。 この回避策は、場合によっては問題を解決することしかでき、毎回ユーザー アカウント制御 (UAC) プロンプトが表示されます。