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デスクトップ用 Power Automateにサインインできない

この記事では、デスクトップ用 Power Automateでのサインインに関連するいくつかの問題の解決策と回避策について説明します。

サインインまたはサインアウトに関する一般的な問題

デスクトップ用 Power Automateでは、msalcache.bin3 という名前のファイルを使用してトークンを取得し、ユーザーを認証します。

サインインまたはサインアウト中にエラーが発生した場合は、このファイルを削除して、格納されているすべてのトークンを削除します。

ファイルを削除するには、MSI インストールの%localappdata%\Microsoft\Power Automate Desktop\Cache\MSIに移動するかMicrosoft ストアのインストール%localappdata%\Microsoft\Power Automate Desktop\Cache\Store

Note

AppData フォルダーがユーザー フォルダーに表示されない場合は、非表示のファイルを表示してみてください

msalcache.bin3 ファイルを削除した後、Power Automate コンソールを閉じ、システム トレイから Power Automate を終了するか、Power Automate サービスを再起動してから、もう一度サインインしてみてください。

Web アカウント マネージャー (WAM)エラー

既定では、デスクトップ用 Power Automateは Web アカウント マネージャー (WAM) (オペレーティング システムに付属し、認証ブローカーとして機能する Windows コンポーネント) を使用してユーザーを認証します。

WAM と関連するエラーの詳細については、「 Web アカウント マネージャー (WAM) を使用した MSAL.NET の使用」および「 WAM でのインターアクティブ」を参照してください。

リージョンの問題が間違っている

サインインする前に、 Change region オプションから適切なリージョンを選択していることを確認します。

Power Automate コンソールの [リージョンの変更] オプションを示すスクリーンショット。

ブラウザーが Cookie をブロックする

デスクトップ用 Power Automateにサインインすると、次のエラー メッセージが表示されます。

サインインできません。 ブラウザーは現在、Cookie をブロックするように設定されています。 Cookie によるこのサービスの使用を許可する必要があります。

解決方法

  1. コントロール パネル>Internet Options>Security>Trusted Sites に移動します。

  2. 次の URL を追加します。

    • login.microsoft.com
    • login.windows.net
    • login.microsoftonline.com
    • secure.aadcdn.microsoftonline-p.com

接続の問題が原因でサインインできない

デスクトップ用 Power Automateにサインインすると、次のエラー メッセージが表示されます。

サインイン中に問題が発生しました。 後でもう一度やり直すか、管理者に問い合わせてください。

問題を確認する

Power Automate にサインインしてみてください。 想定どおりに動作する場合、問題は、デスクトップ用 Power Automateをホストするマシンのローカル ネットワーク構成に関連している必要があります。

解決方法

この問題を解決するための考えられる原因と手順の詳細については、「 デスクトップ フローを作成、編集、保存、または表示できない」を参照してください

ログイン ウィンドウがポップアップし続ける

デスクトップ用 Power Automateにサインインすると、資格情報を入力するとログインウィンドウが表示されます。 疑問符 (?) アイコンを選択して Login のアカウントを Microsoft アカウントにリセットするとログイン ウィンドウが表示されなくなります。

原因

別のプロセスが、同じコンピューター上で名前付きパイプ サーバーを実行している可能性があります。 このプロセスは、localhost エンドポイントを使用して昇格された権限で実行され、他のアプリケーションがこのエンドポイントを使用するのをブロックします。

別のプロセスが実行されているかどうかを識別するには:

  1. Sysinternals Suiteをダウンロードします。

  2. .zip ファイルをフォルダーに抽出します。

  3. 管理者としてコマンド プロンプトを実行します。

  4. Sysinternals Suite が抽出されたフォルダーに移動します。

  5. 次のコマンドを実行します。

    handle net.pipe
    

    Note

    このコマンドを実行すると、名前付きパイプを使用しているプロセスと、そのプロセスがリッスンしているアドレスの一覧が表示されます。

  6. EbmV0LnBpcGU6Ly8rLw==文字列を表示するプロセスがあるかどうかを特定し、次のリンクを使用してプロセスをデコードします。

    https://www.base64decode.org/

    例えば次が挙げられます。

    PAD.BrowserNativeMessageHost.exe pid: 21064 type: Section 464: \Sessions\1\BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rL0JST1dTRVJOQVRJVkVIT1NULzE2NjIwLzEv Microsoft.Management.Services.IntuneWindowsAgent.exe pid: 26708 type: Section 6AC: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rL0lOVFVORU1BTkFHRU1FTlRFWFRFTlNJT04vU1RBVFVTU0VSVklDRS8= PipesTest.Server.exe pid: 6540 type: Section 3AC: \BaseNamedObjects\net.pipe:EbmV0LnBpcGU6Ly8rLw==
    

解決方法

この問題を解決するには、前の手順で特定したプロセスを停止するか、内部プロセスの場合は、 net.pipe://localhost/somethingなどのより具体的なエンドポイントを使用します。

  • 別の方法として、デスクトップ用 Power Automateが (タスク バーからも) 閉じられていることを確認し、前の手順で特定したプロセスを強制終了してから、もう一度デスクトップ用 Power Automate再起動してください。

  • 他のソリューションが不可能な場合は、管理者として実行デスクトップ用 Power Automate実行可能ファイルを指定します。 この回避策は、場合によっては問題を解決するだけで、毎回ユーザー アカウント制御 (UAC) プロンプトが表示される場合があります。