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デスクトップ用 Power Automateの起動時の通信エラー

この記事では、デスクトップ用 Power Automateを起動または開いたときに発生する通信エラーの解決策について説明します。

現象

デスクトップ用 Power Automateを起動または開くと、次のエラー メッセージに "通信エラー" というタイトルが表示されます。

Power Automate コンソールが正常に起動しませんでした。 Power Automate を再起動します。

原因

プロセスは、同じコンピューターで WCF 名のパイプを実行し、他の WCF 名前付きパイプが期待どおりに動作しないようにすることができます。

このプロセスは、localhost エンドポイントを使用して昇格された権限で実行できます。これにより、他のアプリケーションがエンドポイントを使用できなくなります。

問題を確認する

localhost エンドポイントを使用する WCF 名付きパイプがあるかどうかを識別するには:

  1. SysInternals Suite をダウンロードします。

  2. .zip ファイルをフォルダーに抽出します。

  3. 管理者としてコマンド プロンプトを実行します。

  4. 前に抽出した SysInternals フォルダーに移動します。

  5. 次のコマンドを実行します。

    handle net.pipe
    

    Note

    このコマンドは、名前付きパイプを使用するプロセスの一覧と、リッスンするアドレスを表示する必要があります。

  6. 次の文字列を示すプロセスがあるかどうかを特定します。

    EbmV0LnBpcGU6Ly8rLw==

解決方法

この問題を解決するには、問題の原因となるプロセスを停止するか、内部プロセスの場合は、 net.pipe://localhost/abc123などのより具体的なエンドポイントを使用するように構成する必要があります。

回避策

この問題を回避するには、管理者としてデスクトップ用 Power Automateを実行します。

Note

  • 管理者としてプロセスを実行すると、起動するたびにユーザー アカウント制御 (UAC) プロンプトが表示されることがあります。
  • 管理者としてデスクトップ用 Power Automateを実行しても、無人モードでは動作しません。