この記事は、v2 スキーマを持つ環境を開こうとすると発生する "アクセス許可の不足" エラーを解決するのに役立ちます デスクトップ用 Power Automate バージョン 2.46 以降で有効になっています。
現象
デスクトップ用 Power Automate (バージョン 2.46 以降) で v2 スキーマ対応環境を起動または開くと、次のエラー メッセージが表示されます。
この環境でフローを表示または作成することは許可されていません。 管理者に問い合わせるか、既定の環境または十分なアクセス許可がある環境に切り替えます。
原因
この問題は、カスタム ロールが割り当てられている場合、または組み込みロールの既定のアクセス許可が変更された場合に発生します。 このエラーは、インストールされている環境ソリューションを取得する API のアクセス許可に関する問題が原因で発生します。
解決方法
この問題を解決するには、次の手順に従ってください。
- Power Platform 管理センターにサインインしナビゲーション ウィンドウで Environments を選択し、Solution エンティティを管理する環境を選択します。
- 左側のメニューで、 Dataverse を選択します。
- [ Dataverse で Tables を選択します。
- テーブルの一覧で Solution エンティティを検索します。
- Solution エンティティを開き、Permissions タブに移動します。
- "prvReadSolution" 特権を関連するユーザーまたはロールに割り当てます。 つまり、dataverse の Solution エンティティのそれぞれのセキュリティ ロールに対して、Read アクセスを提供する必要があります。