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Microsoft Entra アカウントを使用すると、デスクトップ フローの無効な資格情報エラーが発生する

この記事では、Microsoft Entra アカウントを使用してデスクトップ フローを実行するときに発生するInvalidConnectionCredentialsまたはWindowsIdentityIncorrectエラー コードの解決策について説明します。

適用対象: Power Automate
元の KB 番号: 4555623

現象

Microsoft Entra アカウントを使用してデスクトップ フローを実行すると、 InvalidConnectionCredentials または WindowsIdentityIncorrect エラー コードで失敗します。

{
    "error":{
        "code": "InvalidConnectionCredentials",
        "message": "Could not connect to the Power Automate UI flows Agent. Please make sure that the UI flows connection credentials are valid."
    }    
}
{
    "error":{
        "code": "WindowsIdentityIncorrect",
        "message": "The credentials provided with the request are invalid."
    }    
}

原因

Microsoft Entra アカウントを使用すると、いくつかの理由でエラーが発生する可能性があります。

  • 接続に入力されたアカウント資格情報が、マシン上のものと一致しない可能性があります。
  • Microsoft Entra 認証をサポートするために デバイスが Microsoft Entra 参加済みMicrosoft Entra 参加済みされていない可能性があります。
  • Microsoft Entra アカウントがコンピューターに同期されていない可能性があります。

解決方法

  1. デバイスが Microsoft Entra に参加しているか、ドメインに参加していることを確認します。

    1. コマンド プロンプトを開きます。

    2. dsregcmd /status コマンドを実行します。

    3. Device Stateセクションを確認します。

      dsregcmd /status を実行するときのコマンド プロンプトのデバイスの状態のスクリーンショット。

      DomainJoined値またはAzureAdJoined値のいずれかがYESされていることを確認します。

      そうでない場合は、デバイスが参加していない限り、Microsoft Entra アカウントを使用できません。 詳細については、「 デバイスを参加させる方法を参照してください。

  2. マシン構成で使用する Microsoft Entra アカウントを特定します。

    1. Settings を開き、Accounts を選択します。

    2. [職場または学校 アクセス] を選択

    3. "Connected to <your_organization> Microsoft Entra ID" のようなテキストが表示されていることを確認します。接続されているアカウントは、接続で使用できます。

  3. デバイスで Microsoft Entra アカウントを同期します。

    1. Access の職場または学校 ページで Microsoft Entra 接続を選択するときに、Info ボタンを選択します。

    2. これにより、接続情報とデバイス同期の状態を説明するページが開きます。 ページの最後にある Sync ボタンを選択し、このプロセスが完了するまで待ちます。

  4. 構成された Microsoft Entra アカウントがデバイスにサインインできることを確認します。

    1. 手順 2 で識別された Microsoft Entra アカウントを使用して、コンピューターにサインインしてみてください。
    2. 接続で使用するには、デバイスログインが成功している必要があります。
  5. フローが適切なユーザー名とパスワードで正しく構成されていることを確認します。 これは、コンピューター上のアカウントと一致している必要があります。

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