Windows Server 2012のアプリケーション ログのエラー 1032 メッセージ

この記事は、Windows Server 2012を実行しているコンピューターでSQL ServerまたはSQL Server Analysis Servicesのインスタンスを実行しようとしたときに発生する問題を解決するのに役立ちます。

元の製品バージョン: SQL Server Analysis Services、SQL Server
元の KB 番号: 2811566

現象

次のような状況で問題が発生します。

  • Windows Server 2012を実行しているコンピューターに Microsoft SQL ServerまたはSQL Server Analysis Servicesをインストールします。
  • インストール時に、これらのアプリケーションのサービス アカウントとして既定のアカウントを使用します。
  • インストールが成功しました。
  • インストール後、これらのプログラムのサービスは正常に開始されます。

このシナリオでは、アプリケーション ログに次のようなエラー メッセージが表示される場合があります。

  • SQL Server (SQLServr.exe) のインスタンスの場合

    sqlservr (3472) 読み取り専用アクセスのファイル "C:\Windows\system32\LogFiles\Sum\Api.log" を開こうとしたが、システム エラー 5 (0x00000005) で失敗しました: "アクセスが拒否されました。 ". 開いているファイル操作はエラー -1032 (0xfffffbf8) で失敗します。
    sqlservr (3472) エラー -1032 (0xfffffbf8) は、ログ ファイル C:\Windows\system32\LogFiles\Sum\Api.log を開くときに発生しました。

  • SQL Server Analysis Servicesのインスタンス (Msmdsrv.exe) の場合

    msmdsrv (4680) 読み取り/書き込みアクセス用のファイル "C:\Windows\system32\LogFiles\Sum\Api.chk" を開こうとしたが、システム エラー 5 (0x00000005) で失敗しました: "アクセスが拒否されました。 ". 開いているファイル操作はエラー -1032 (0xfffffbf8) で失敗します。
    msmdsrv (4680) エラー -1032 (0xfffffbf8) は、ログ ファイル C:\Windows\system32\LogFiles\Sum\Api.log を開くときに発生しました。

原因

この問題は、ソフトウェア使用状況メトリック機能の一部として、サービスがログ記録のために次のフォルダーにアクセスするときに、SQL ServerとSQL Server Analysis Servicesのサービススタートアップ アカウントに対するアクセス許可が不十分であるために発生します。

C:\Windows\System32\LogFiles\Sum

回避策

この問題を回避するには、フォルダーにアクセスするためにSQL Server (sqlservr.exe) とSQL Server Analysis Services (msmdsrv.exe) によって使用されるサービス アカウントに、読み取り/書き込みアクセス許可を\Windows\System32\LogFiles\Sum手動で追加します。

詳細

ソフトウェア使用状況メトリック機能は、Windows Server 2012でユーザー アクセス ログ サービスを使用します。 詳細については、「 ユーザー アクセス ログの概要」を参照してください。