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SQL Server の使用時に評価期間が期限切れになったというエラー メッセージ

この記事は、SQL Server Management Studio (SSMS) や SQL Profiler などの Microsoft SQL Server ツールを使用するときに発生する問題を解決するのに役立ちます。

元の製品バージョン: SQL Server
元の KB 番号: 971268

現象

SQL Server Management Studio (SSMS) や SQL Profiler などの SQL Server ツールを使用すると、次のエラー メッセージが表示されることがあります。

評価期間が切れています。 評価版ソフトウェアをアップグレードする方法については、 https://www.microsoft.com/sql/howtobuyを参照してください。

さらに、SQL Server インスタンスの有効期限が切れたインストールに接続しようとすると、次のエラー メッセージが表示される場合があります。

SQL Server への接続を確立しているときにネットワーク関連またはインスタンス固有のエラーが発生しました。 サーバーが見つからないかアクセスできません。 インスタンス名が正しいこと、および SQL Server がリモート接続を許可するように構成されていることを確認してください。 (プロバイダー: 名前付きパイプ プロバイダー、エラー: 40 - SQL Server への接続を開けませんでした)。

Note

接続エラー メッセージは汎用メッセージであり、SQL Server インスタンスの有効期限が切れたインストールに関連付けられているとは限りません。

原因

この問題は、通常、SQL Server の評価インスタンスを実行していて、評価期間の有効期限が切れている場合に発生します。

Note

SQL Server 2008 の場合、既知のバグが原因でライセンスバージョンにアップグレードした後でも、このエラー メッセージが表示されることがあります。

解決方法

  • ケース 1 - SQL Server 評価版のバージョンが期限切れである

    Note

    これは、評価版からツールのみがインストールされるシナリオにも当てはまります。

    Evaluation Edition をリテール エディションにアップグレードするには、オンライン ブックで次のトピックを参照してください。

    Note

    これらのトピックのいずれかで、上部にあるバージョン ピッカー ツールを選択して、環境に関連するトピックを選択できます。 SQL Server 2008 については、サポート技術情報の記事「 SQL Server の別のエディションへのアップグレード (セットアップ)」を参照することもできます。 SQL Server 2005 については、別のエディションの SQL Server (セットアップ) にアップグレードする方法に関するサポート技術情報の記事を参照してください。

  • ケース 2 - エンタープライズ評価版から Express Edition への移行

    場合によっては、Enterprise 評価版から Express エディションに移行する場合があります。 使用できるアップグレード パスがないため、評価版から Express Edition へのユーザー データベースの移動については、次の記事を参照してください。

    Note

    SQL Express エディションの最大リレーショナル データベース サイズは 10 ギガバイト (GB) です。

    • シナリオ 2 - 評価期間の有効期限が切れているため、Enterprise 評価版の期限切れのエディションを開始できません

      データベース サイズが 10 ギガバイト (GB) 未満の場合は、次の手順を実行できます。

      1. 製品の express edition をインストールします。

      2. データベースのデータ ファイル (mdf ファイルと ldf ファイル) を見つけます。

      3. これらのファイル SQL Express Edition にアタッチします。

        Note

        データ ファイルを SQL Express エディションにアタッチする前に、これらのファイルが現在古いインスタンスの既定のデータ ディレクトリにある場合は、データベース ファイルを現在の場所から新しいインストール用の新しいデータ ディレクトリまたはサーバー上の別の場所に移動できます。

  • ケース 3 - ライセンス版の SQL Server にアップグレードした後でも、SQL Server 2008 環境でこの問題が発生している

    この場合、次のオプションがあります。

    Note

    また、共有ツールの評価版を最初にインストールし、後でライセンス版にアップグレードしたシステムでも、この問題が発生します。

    • オプション 1

      評価版をライセンス版にアップグレードする前に、SQL Server 2008 用 Service Pack 1 を適用します。

      Note

      SQL Server 2008 用 Service Pack 1 を適用する前にエディションのアップグレードを既に実行していた場合は、オプション 2 セクションで説明されているすべての手順を実行して問題を解決する必要があります。 Service Pack は、将来のエディションのアップグレードに関連する問題のみを防ぎます。

    • オプション 2

      この問題を解決するには、次の手順に従います。

      重要

      このセクション、方法、またはタスクには、レジストリの編集方法が記載されています。 レジストリを誤って変更すると、深刻な問題が発生することがあります。 したがって、次の手順を注意深く実行してください。 保護のために、レジストリを変更する前に、バックアップします。 その後、問題が起こった場合は、レジストリを復元できます。 レジストリのバックアップと復元方法の詳細は、「Windows のレジストリのバックアップおよび復元の方法」を参照してください。

      1. Start>Run を選択し、「Regedt32」と入力し、OK を選択します。

      2. レジストリ エディターで次のキーを見つけて選択します。

        HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\100\ConfigurationState

      3. Registry エディターの右側のウィンドウでCommonFiles (DWord の種類) 選択します。

      4. [編集] メニューの [修正] を選択します。

      5. 3」と入力し、 OK を選択します。

      6. レジストリ エディターを終了します。

      7. アップグレードを別のエディションの SQL Server (セットアップ) に再実行手順を実行して、すべてのコンポーネントをライセンスされたエディションにアップグレードします。

SSMS の有効期限が切れるかどうかを確認する

  1. SQL Server Management Studio を起動します。
  2. Help メニューを選択し、一覧から About... サブメニューを選択します。 Microsoft SQL Server Management Studio コンポーネントの横に 'x' 日 が含まれている場合は、記事で説明されている問題が発生します。

適用対象

  • SQL Server 2008 Developer
  • SQL Server 2008 Enterprise
  • SQL Server 2008 Standard
  • SQL Server 2008 Web
  • SQL Server 2008 Workgroup
  • SQL Server 2008 R2 Developer
  • SQL Server 2008 R2 Enterprise
  • SQL Server 2008 R2 Express with Advanced Services
  • SQL Server 2008 R2 Standard
  • SQL Server 2008 R2 Standard Edition for Small Business
  • SQL Server 2012 Developer
  • SQL Server 2012 Enterprise
  • SQL Server 2012 Express
  • SQL Server 2012 Standard
  • SQL Server 2012 Web
  • SQL Server 2012 Enterprise Core
  • SQL Server 2014 Developer
  • SQL Server 2014 Enterprise
  • SQL Server 2014 Enterprise Core
  • SQL Server 2014 Express
  • SQL Server 2014 Standard