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Windows 7 ベースのコンピューターでバックアップおよび復元ウィザードを使用してファイルをバックアップしようとすると、エラー コード0x81000031が発生する

この記事では、Windows 7 のバックアップおよび復元ウィザードを使用して外部ハード ディスク ドライブにファイルをバックアップするときに発生する問題について説明します。

適用対象: Windows 7 Service Pack 1
元の KB 番号: 975692

現象

次のシナリオで考えてみましょう。

シナリオ 1: カスタム ライブラリが使用できない

  • Windows 7 を実行しているコンピューターがある。
  • リムーバブル ドライブまたはネットワーク ドライブ上にあるカスタム ライブラリを追加します。
  • 1 つ以上のカスタム ライブラリが使用できない場合は、バックアップを実行しようとします。

このシナリオでは、Windows バックアップと復元ウィザードを使用してファイルをバックアップしようとすると、次のメッセージのようなエラー メッセージが表示されます。

エラー コード: 0x81000031

シナリオ 2: BitLocker ドライブ暗号化が有効になっている

  • Windows 7 を実行しているコンピューターがある。
  • 外部ハード ディスク ドライブをコンピューターに接続します。
  • システム ドライブで Windows BitLocker ドライブ暗号化を有効にします。

このシナリオでは、Windows バックアップおよび復元ウィザードを使用してファイルを外部ドライブにバックアップしようとすると、次のメッセージのようなエラー メッセージが表示されます。

重要な BitLocker システム ファイルが見つからないか破損しているため、BitLocker ドライブ暗号化を使用できません。

エラー コード: 0x81000031

原因

シナリオ 1: カスタム ライブラリが使用できない

この問題は、Windows バックアップ ウィザードを使用してバックアップを実行するときにアクセスできないカスタム ライブラリを追加した場合に発生する可能性があります。 これらのライブラリが使用できないネットワーク ドライブ上にある場合、またはそれらのライブラリがリムーバブル メディアに配置されている場合は、カスタム ライブラリが使用できなくなる可能性があります。

シナリオ 2: BitLocker ドライブ暗号化が有効になっている

この問題は、BitLocker ウィザードが Windows 回復環境 (Windows RE) をシステム ドライブから外部ハード ディスク ドライブに移動するために発生します。 これにより、外部ハード ディスクにバックアップを作成できなくなります。

回避策

この問題を回避するには、シナリオに適した手順に従います。

シナリオ 1: カスタム ライブラリが使用できない

ライブラリを既定のライブラリ (ドキュメント、音楽、画像、ビデオ) にリセットするには、次の手順に従います。

  1. [スタート] をクリックし、[ Computer] をクリックします。

  2. エクスプローラー ウィンドウの左側にあるナビゲーション ウィンドウで Libraries を右クリックし、[ 既定のライブラリの再ストア] をクリックします。

    Note

    この操作により、ライブラリの場所にあるカスタム ライブラリが削除されます。 ライブラリの場所が再び使用可能になったときに、これらのライブラリを復元できます。

  3. バックアップと復元ウィザードを起動して、ファイルとデータをバックアップします。

シナリオ 2: BitLocker ドライブ暗号化が有効になっている

BitLocker ドライブ暗号化を無効にして再度有効にするには、次の手順に従います。

  1. 外付けハード ディスク ドライブをコンピューターに接続します。 外付けハード ディスク ドライブの電源がオンになっていることを確認します。

  2. Windows 7 システム修復ディスクを作成します。これを行うには、次の手順に従います。

    1. [ Start] をクリックし、[ Start Search ボックスに「create a system repair disc」と入力します。
    2. Programsの一覧で、システム修復ディスクの作成をクリックします。
    3. 画面の指示に従ってディスクを作成します。

    Note

    システム修復ディスクを作成するには、CD または DVD バーナーが必要です。

  3. 管理者特権でコマンド プロンプトを開始します。 これを行うには、次の手順を実行します。

    1. [ Start] をクリックし、[ Start Search ボックスにコマンド プロンプトを入力します。
    2. Programs一覧でコマンド プロンプトを右クリックし、[管理者として実行] をクリック
  4. 管理者特権でのコマンド プロンプトで、次のコマンドを入力し、Enter キーを押します。

    C:\Windows\System32\REAgentC.exe /disable
    
  5. 外付けハード ディスク ドライブを取り外します。

  6. 管理者特権でのコマンド プロンプトで、次のコマンドを入力し、Enter キーを押します。

    C:\Windows\System32\REAgentC.exe /enable
    

    Note

    この操作は失敗する可能性があります。 この場合、回復ツールにアクセスする必要がある場合は、手順 2 で作成した Windows 7 システム修復ディスクを使用します。

  7. 外付けハード ディスク ドライブをコンピューターに再接続します。

  8. バックアップと復元ウィザードを起動して、ファイルとデータを外部ハード ディスク ドライブにバックアップします。

詳細

システム修復ディスクを作成して使用する方法の詳細については、次の Microsoft Web サイトを参照してください。

システム修復ディスクを作成する

状態

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。