この記事では、自動修復が失敗した後に PC を更新またはリセットできない問題を修正します。
適用対象: Windows 8
元の KB 番号: 2823223
現象
以下のシナリオについて考えてみます。
- PC に Windows 8 または Windows 8 Pro がインストールされている。
- PC が Windows で起動できず、自動修復が起動して Windows の修復が試みられます。
- 自動修復はPCを修復できず、 オプションを選択。
- [トラブルシューティング]を選択した後
PCを表示するか PCを設定します。
このシナリオでは、回復が失敗し、メインの WinRE 画面に戻ります。
原因
この問題は、システムまたはソフトウェアのレジストリ ハイブが破損または破損した場合に発生する可能性があります。
解決方法
この問題を解決するには、次の手順に従います。
Note
これらの手順は、を使用しようとしている場合にのみ使用する必要があります
自動修復が PC の修復に失敗した後、 [Advanced options を選択し、 トラブルシューティング。
Advanced オプションを選択しコマンド プロンプトを選択します。
メッセージが表示されたら、ユーザー名のパスワードを入力します。
コマンド プロンプトで、次のコマンドを入力して \windows\system32\config フォルダーに移動します。
cd %windir%\system32\config
次のコマンドを使用して、System および Software レジストリ ハイブの名前を System.001 および Software.001 に変更します。
ren system system.001 ren software software.001
Note
ソフトウェア ハイブの名前を変更しても、[PC の更新] オプションを使用することはできません。 [PC の更新] オプションを使用する場合は、システム ハイブの名前のみを変更します。 ソフトウェア ハイブも破損している場合は、[PC の更新] オプションを使用できない可能性があります。
引用符なしで「 exit を入力してコマンド プロンプトを終了し、PC を再起動して自動修復画面に戻します。
[Advanced オプション]を選択した後[トラブルシューティング]を選択 PC を表示するか
PC を設定します 。
詳細
を使用して PC をリセット オプションを使用すると、ハード ドライブ上のすべてのファイルが削除され、PC 上の OEM によってプレインストールされた Windows 8 のバージョンに PC がリセットされます。 購入後に PC にインストールされたすべての新しいアプリケーションを再インストールする必要があります。