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リモート プロシージャ コール サービスが無効になっている場合、一部の Windows プロシージャが機能しない

この記事では、リモート プロシージャ コール (RPC) サービスが無効になっているときに一部の Windows プロシージャが機能しない問題の解決策を示します。

元の KB 番号: 830071

重要

この記事には、レジストリの変更に関する情報が含まれています。 レジストリを変更する前に、レジストリのバックアップを必ず作成し、問題が発生した場合にレジストリを復元する方法について確実に理解しておいてください。 レジストリをバックアップ、復元、および編集する方法の詳細については、「上級ユーザー向けの Windows レジストリ情報」を参照してください。

現象

Microsoft Windows NT 4.0、Microsoft Windows 2000、Microsoft Windows Server 2003、または Microsoft Windows XP を実行しているコンピューターを再起動すると、次の条件が発生する可能性があります。

  • デスクトップ上でアイコンを移動することはできません。
  • イベント ログ エントリを表示することはできません。
  • サービス Microsoft 管理コンソール (MMC) を開くことができますが、一覧にサービスが表示されません。

原因

この問題は、RPC サービスを無効にした場合に発生する可能性があります。 多くの Windows オペレーティング システムの手順は、RPC サービスに依存します。

RPC サービスを無効にしないことをお勧めします。

解決方法

警告

レジストリ エディタの使用を誤ると、オペレーティング システムの再インストールが必要になるような深刻な問題を引き起こす可能性があります。 レジストリ エディターの不適切な使用によって生じた問題については、解決を保証できません。 リスクを理解した上でレジストリ エディターを使用してください。

この問題を解決するには、次の手順に従ってください。

  1. [ 開始] をクリックRun をクリックし、「 regedt32」と入力して、[ OK] をクリック
  2. レジストリ キーの HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\RpcSs\を展開します。
  3. Startをダブルクリックし、[DWORD 値の編集] ダイアログ ボックスに「2」入力し、[OK] をクリック
  4. レジストリ エディターを閉じ、コンピューターを再起動します。

コンピューターが正しく起動しない場合は、回復コンソールを使用して RPC サービスを再度有効にすることができます。 回復コンソールを使用するには、次の手順に従います。

  1. 回復コンソールにコンピューターを起動します。
  2. 回復コンソールのコマンド プロンプトで、 Enable RPCSS Service_Auto_Start コマンドを入力し、Enter キーを押します。
  3. 回復コンソールのコマンド プロンプトで、「 EXIT」と入力し、Enter キーを押します。
  4. コンピューターを再起動します。

詳細

次のサービスは RPC サービスによって異なります。

  • バックグラウンド インテリジェント転送サービス
  • COM+ イベント システム
  • 分散リンクの粘着クライアント
  • 分散トランザクション コーディネーター
  • FAX サービス
  • インデックス サービス
  • IPSec ポリシー エージェント
  • Messenger
  • ネットワーク接続
  • 印刷スプーラー
  • 保護された記憶域
  • リムーバブル ストレージ
  • ルーティング情報プロトコル (RIP) リスナー
  • ルーティングとリモート アクセス
  • タスク スケジューラ
  • テレフォニー
  • Telnet
  • Windows インストーラー
  • Windows Management Instrumentation (Windows Management Instrumentation)

関連情報

Windows XP、Windows 2000、または Windows Server 2003 で回復コンソールを使用する方法の詳細については、「 Windows? のシステム回復オプションと 起動しない Windows Server 2003 ベースのコンピューターで回復コンソールを使用する方法を参照してください。