次の方法で共有


ドキュメントをスキャンしようとすると、"サーバーがビジー状態" というエラー メッセージが表示される

この記事では、ドキュメントをスキャンしようとしたときに "サーバービジー状態" エラーを修正するための解決策を示します。

適用対象: Windows 10 - すべてのエディション
元の KB 番号: 2971655

現象

以下のシナリオについて考えてみます。

  • 64 ビット (x64) バージョンの Windows 8.1、Windows 8、または Windows 7 を実行している。
  • 32 ビット スキャン アプリケーションを実行している。
  • TWAIN 1.0 の既定のインターフェイスを使用するスキャナーを使用しています。
  • ドキュメントをスキャンしようとするとします。

このシナリオでは、"何をスキャンしますか?" というメッセージが表示されます。 メッセージ ウィンドウには、スキャナーを構成するためのオプションも表示されます。 数秒後に、次のエラー メッセージが表示されます。

サーバー ビジー

原因

この問題は、32 ビット スキャン アプリケーションが 64 ビット バージョンの Windows で実行されているために発生します。 このような状況では、スキャナーのドライバーは、別のWiawow64.exeプロセス中に読み込まれます。 "何をスキャンしますか?" というメッセージは、Wiawow64 プロセスの一部です。 エラー メッセージは、32 ビット スキャン アプリケーションからの OLE 呼び出しによって発生します。 この問題は、スキャン アプリケーションが [何をスキャンしますか? ] ウィンドウでユーザー入力を待機している間に期限切れになるタイムアウト値があるために発生します。

解決方法

この問題を解決するには、スキャンアプリケーションベンダーに連絡して、アプリケーションを更新してもらうことをお勧めします。

詳細

開発者の場合は、次の情報を参照してください。

AfxOleInit()を呼び出すとき。関数の場合、 m_nTimeout パラメーターは既定値の 8 秒に設定されます。 OLE 呼び出しのタイムアウトを無効にするには、AfxOleInit()を呼び出した後に次の行を追加する必要があります。機能:

AfxOleGetMessageFilter()->EnableNotRespondingDialog(FALSE);

データ収集

Microsoft サポートからのサポートが必要な場合は、ユーザー エクスペリエンスの問題に TSS を使用して、 Gather 情報に記載されている手順に従って情報を収集することをお勧めします