この記事では、コンピューターを Windows 10 バージョン 1709 にアップグレードした後に sysprep がエラーで失敗する問題の回避策について説明します。
適用対象: Windows 10 バージョン 1709
元の KB 番号: 4057974
現象
以下のシナリオについて考えてみます。
Windows 10 バージョン 1703 ベースのコンピューターでは、MiracastView は組み込みのアプリであり、既定でインストールされます。
コンピューターを Windows 10 バージョン 1709 にアップグレードします。
管理者権限でコマンド プロンプト ウィンドウを開き、次のコマンドを実行します。
cd %windir%\System32\Sysprep sysprep.exe /generalize /oobe /reboot
このシナリオでは、sysprep コマンドは失敗します。 次のようなエラー メッセージが表示されます。
Sysprep で Windows のインストールを検証できませんでした。 詳細については、%WINDIR%\System32\Sysprep\Panther\setupact.log のログ ファイルを確認してください。 問題を解決したら、Sysprep を使用してインストールを再度検証します。
さらに、setupact ログには、次のようなエラー メッセージが含まれています。
日付/時刻、エラー SYSPRP パッケージ Windows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewy がユーザーにインストールされましたが、すべてのユーザーに対してプロビジョニングされていません。 このパッケージは sysprep イメージで正しく機能しません。
日付/時刻、エラー SYSPRP 現在のユーザーのアプリを削除できませんでした: 0x80073cf2。
日付/時刻、エラー SYSPRP RemoveAllApps スレッドの終了コードが0x3cf2されました。
日付/時刻、エラー SYSPRP ActionPlatform::LaunchModule: C:\Windows\System32\AppxSysprep.dll から 'SysprepGeneralizeValidate' の実行中にエラーが発生しました。dwRet = 0x3cf2
日付/時刻、エラー SYSPRP SysprepSession::Validate: C:\Windows\System32\Sysprep\ActionFiles\Generalize.xml からのアクションの検証中にエラーが発生しました。dwRet = 0x3cf2R
Remove-AppxPackage PowerShell コマンドを使用して MiracastView を削除すると、コマンドは機能せず、次のエラー メッセージが表示されます。
パッケージ Windows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewy のターゲット ボリューム C: での展開の削除操作は、エラー 0x80070490で失敗しました。
アプリのデプロイの問題の診断については、http://go.microsoft.com/fwlink/?LinkId=235160
を参照してください。
原因
この問題は、アップグレード中にセットアップで Windows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewy パッケージを移行する方法のバグが原因で発生します。 このパッケージは、一般化されたイメージでは正しく機能しません。
回避策
この問題を回避するには、以下のいずれかの方法を使用します。
方法 1
Windows 10 バージョン 1709 コンピューターで、Windows.MiracastView_6.3.0.0_neutral_neutral_cw5n1h2txyewy.xmlを C:\Windows.old\ProgramData\Microsoft\Windows\AppRepository\ から C:\ProgramData\Microsoft\Windows\AppRepository にコピーします。
方法 2
Windows 10 バージョン 1703 コンピューターから Windows 10 バージョン 1709 コンピューターに C:\Windows\MiracastView フォルダーをコピーします。 次に、コンピューターを再起動して、Windows が MiracastView のアンインストールを完了できるようにします。
データ収集
Microsoft サポートの支援が必要な場合は、「展開関連の問題について TSS を使用して情報を収集する」に記載している手順に従って情報を収集することをお勧めします。